Retrologue is too tiny on my screen

Cubase Noob here. I thought I would check out Retrologue for the first time, but it’s coming out TINY on my display. Too small to work with in practice. I’m not having this problem with other instruments.


I’ve attached two screenshots for comparison. How do I fix this?

Thanks in advance.

Found the solution. Retrologue has a setting called “High DPI Mode” which can be invoked for running on high resolution monitors. How it defaulted to NOT being in that mode on a 4K monitor is a mystery.

I’m a retired software engineer with decades of experience in Windows and Android software design and I’m baffled by the need for such a setting. Windows provides lots and LOTs of ways for a competent programmer to design windows and controls to automatically adjust their dimensions or layout to fit within a particular screen or parent-window or whatever the user-experience calls for. I’ve seen beginning and student programmers struggle with resizing issues, but I don’t expect the pro’s to have any problems with it.
(… or is that what’s supposed to be “retro” about this instrument? Maybe it’s supposed to seem like it was programmed in version 1.0 of Visual Basic in classic Windows 3.1 from 1991?)