Retrospective Record problems after 7.5.30 update

I can give you a repro, but its a specific case that solved my retrospective problem in cubase 8, not sure if it’ll work for 7.5.3. I use the IAC bus to transfer MTC from the project synchronization setup to a program called “video slave”. The solution to solve the retrospective problem was to remove the IAC bus from the “All MIDI Inputs” in the device manager, which is what the input to all my midi tracks is. Once I did that the problem was solved. This can be tested:

  1. Set up an IAC bus in the MIDI setup on a Mac

  2. go to Project Synchronization setup and send MTC out that IAC bus.

  3. make sure IAC is selected and active in the “All MIDI inputs” in the the device manager.

  4. make a midi track which as an input of “All MIDI inputs” and try to use retrospective record. It will not work.

  5. now go back to device manger and remove IAC bus from “All midi inputs”. and retrospective should be have as expected.

I did not have to do this prior to 7.5.3, so I’m not sure what the problem is, but it’s easily solved using this method.


I’ve been experiencing the same problem on 8.05. I’m using MidiOverLan (via ethernet) to sync with a protools computer and Lemur (via wifi) for key commands, etc. I was also able to work around the problem by disabling “All MIDI Inputs” for the midioverlan midi channel. All is working well when this is unchecked. Fantasiom, thank you, you saved my life…I thought I was going to have to go back to 7.5.2!

I’m having an issue in Cubase 8.0.5 on Mac (10.9.5) where my retrospective record is most definitely NOT what I played in. I check by retrospective record and recording at the same time and the retrospective record midi was about a 32nd note ahead of the recorded midi (which sounded correct). I’m not sure what’s going on here, but it’s very annoying as I use RR as my main method of inputting midi (and I know several people that do the same). Seems like it’s unusable for the time being…

I do have a lemur and have Midi over Lan syncing a ProTools rig as well. Have them both turned off in “all midi” but still no dice.

if turning select things off in the All MIDI column of device manager doesn’t work, also try just changing the input of the midi track to one specific midi device, your keyboard, and see if the same problem exists…