Retrospective record??

hi guys,

I can’t make the midi retrospective record to work? it’s set in the Preferences, but doesn’t actually do anything. A pop up says “no midi data in buffer”, or something similar.

Any idea? I’m totally lost without it, I use it all the time.


edit: forgot to say I’m on Cubase 9 Pro

Hi Alex,

I use this all the time and can’t live without it either.

Are you using a midi controller or the virtual keyboard within Cubase?


Hi Ever,

I use a midi keyboard controller. Never had this issue up to now and this started with 9.0. My gear is still the same as well as my system.

Have you had any similar issue?

I also use a nektar midi controller and have never had problems with retrospective recording since Cubase 8.

My advice would be to check and see if you are updated with your midi controller drivers/software. If you are, then I suggest you trash your preferences to see if that helps.

I am not completely positive, but I think that instrument/midi tracks have to be armed in order to have retrospective record working. There is a preference for having tracks automatically armed on selection. Maybe you have disabled it?

No, it’s all properly set. You are right, the track must be armed in order for the retrospective rec to work.
Except mine is. ot working. Since many things changed places in Cubase 9, I thought I was missing something

Together with enabling retrospective record (tick box) there has to be a “retrospective record buffer size” set to a value greater than zero on the same preference page. Could you check if it was set correctly?

Yep zyguli,

It´s all set as it should be.
It´s working fine in Cubase 8.5 with the same settings, I just checked.

Worth trying. Cubase Safe mode:

Hi Ziguli, I didn’t know that one, thanks!!

I’m surely trying this out tomorrow at the Studio. I’ll get back to you with the out come.

If anything else to help, please keep it coming. Cheers

No problem. Report back. :slight_smile:

Hey, it worked! Well, it worked to show that my Preferences is messed up… My retrospective record is working in Safe mode.

What should I do in this case? I was a lucky user and never had any issue with any of the previous version, I don’t know how to fix my Preference…

Please follow these instructions:

hey Nickel,

Yep, I could do that. But the thing is, I will loose all my preferences, including my studio setup and so forth…

my question is… is there a way to copy my preferences from Cubase 8.5, or something?

I must say I’m a bit dissapointed with C9. I “never” had any problem up to now but C9 is sluggish and has many issues. I can’t understand why these issues after a bloody stable 8.5.,

I’ve spotted dozens of them up to now. for instance, record delay compensation is working erratically. I was doing this Brass recording session yesterday and my delay compensation was pressed, but the latency was still in place. I had to re-enable it …

Hi Alexandre,

You could choose to rename the preferences folder. After starting Cubase again it will create a new and fresh preferences folder. Now you can copy the things back that are important to you. However, some parts will not be touched. Read the following article:

You can find a more in depth explanation about the preferences here:

I noticed myself that some projects created on pre C9 versions have some minor but irritating issues sometimes. I had one where it would keep transmitting to the track that was previously selected. So it would transmit on 2 separate midi channels at the same time while only one was selected. Re-saving it in C9 seemed to have solved it.

Anyway, I hope you can sort this out.

thanks Nickeldome, I will check it out.

So, I wiped out the preferences. I was hoping the performance issue I’m having would go away, but it didn’t.
Here, Cubase 9 is suffering from performance issues… and it can only be C9, since I tested all my previous install. Cubase 8.5 is a lot faster, 9 is kind of sluggish.

did you noticed anything similar in performance, comparing to 8.5?

I have versions starting from C7.5 on my current installation and the former became sluggish after installing C8.5. I had to turn off Hyper threading to optimize it. After installing C9 I had to set the preferences for audio again. I now have it set to enable ‘Activate Multi Processing’ and ‘Asio Guard’ (normal). And C9 seems to prefer Hyper Threading enabled on my system while C8.5 did not so much. Also make sure you have an optimized power profile selected. Not necessarily the ‘Steinberg Audio Power Scheme’ but it’s a good starting point for a quick test. Besides this it depends what works best with your system/setup. Trial and error is the only way to really find out. I really do hope that someday Steinberg will get a grip on this reoccurring performance problem.