Reverb Foundry’s M7 Link not working in Cubase Pro 10.5.12

For the last few months I have been happily using Digital Foundry’s M7 Link to control my Bricasti M7 from within Cubase Pro 10.5.12 until a week or so ago when it stopped connecting. I have contacted Digital Foundry and run it by them but after trying a few things , I’m still not able to get the plugin to talk to the M7.the M7 is connected to my PC via a Roland Um-one interface which according to Reverb Foundry, is 100% compatible.

I have a trial of Nuendo installed and out of curiosity , I loaded it up and loaded an instance of the plugin and it works perfectly.
I have compared the MIDI settings in the Studio Manager menu in both Cubase and Nuendo just in case something was different , but they are set exactly the same.

Anyone have any ideas?


Same issue here.
M7 Link works fine on cubase 10 but does not connect to the hardware on cubase 10.5.12…
I found no solution yet…still working on it.

Midi filter could be different, check that first.

Thank you, yes i did. Everything ok on this side.
Problem solved by simply reinitializing the midi ports on the midi configuration page!

M7 hardware is responding great now to the M7 link.
Great plug in!!!