Reverse Cymbal Note Length.

Very New Newbie here so please be kind.
Using Elements 7, Win7, Virtual keyboard and included instruments only at this stage.
Managed to get some basic Midi tracks down but struggling with something I can’t work out. I have a Reverse Cymbal sound on a separate track in a project that comes from Halionsonic GE Reverse Cymbal(GM120). Each key on the virtual keyboard represents a different pitch and note length from low/long reverse cymbal sound to high/short. I select the one that fits exactly to the length of sound I want and it’s all good and save the project. Whenever I re-open the project and begin playback the note length is shortened for some reason. It’s still the same length visually in the editor but cuts out halfway along during playback.
If I open up the Halionsonic editor in the track and go right up to the highest note on the virtual keyboard (using the arrows to scroll right up there) and play that note which is mini second short it resets everything and makes all the notes in the instrument longer again. Then when I play the track the original note length is fine and long again. I have to do this each time I work on the project to get the note length to it’s original length.
Sorry If I haven’t explained it well.

I believe I have understood your explanation. I placed a MIDI note B0 on the MIDI track directed to HALion Sonic SE with the GM MIDI 120 Reverse Cymbal sound loaded. It played the sample to completion. I saved the project and reloaded it and the sample played to completion still. If you would like to place a bare bones project in Dropbox or something, I can download it and try it to see if I can find anything.
HTH
J.L.

Thanks for the reply.
I had no issues for the first few weeks and got the same result you did. It’s only started doing it recently. I think it might be some kind of setting I’ve changed in Halsonic without realising, whilst looking around. I actually don’t need to put a note in the project editor to replicate the issue I’ve realised. If I just go into Halsonic editor/player in a bare bones project from the Hub and bring up the GM120 in any track and put mouse arrow over halsonic keyboard and press and hold B0, the note plays for .5 of a second and then cuts off automatically without really resolving to a “crescendo” end. If I then go up the keyboard and play G8 , then go back and press and hold B0 the note now plays for almost 2 seconds before resolving/finishing to a “crescendo” automatically (which is what I want).
Could you emulate holding down the note in halsonic as described and see if your note length changes.
Sorry again as I’m so new to this stuff but where is the drop box?
Appreciate your time

Aloha guys,

This is a great thread and I sure hope you guys figure it
because this one (like many others) has escaped me for years.

And not just HalionSonic stuff. I have had this issue
with other 3rd party VSTi’s as well.

]I

f I then go up the keyboard to G8 and play it, then go back and press and hold B0 the note now plays for almost 2 seconds before resolving/finishing automatically (which is what I want).

BINGO!
I thought perhaps this is similar to a ‘close/open hi-hat’ thing where one sound
shuts the other but in reverse; where one sound actually ‘lengthens’ the other.

Wrong. None of my experiments yielded positive results.

Here is hoping you guys nail it. TIA
{’-’}

Dropbox is a website where you can save files and then share them with others. Any file sharing/hosting site would do but I have a feeling it is something in the instrument and not the project anyway.

The only thing I can think of is that you have assigned a trgger pad with an arpeggio or FlexPhraser to the program and the G8 key is assigned to a different pad without a phrase.

If you have changed those assignments on the GM120 program, and saved it, reinstalling Cubase should return the program to it’s original form (actually, you would just need to reinstall the HALion Sonic SE content.)

If the problem is with the defaults for the instrument, or if the defaults file is corrupted, you will have to delete the defaults.xml file (reinstalling does not delete the file).
It is located in a hidden folder in \《user》\AppData\Roaming\Steinberg\Halion sonic
Just drag it to the desktop.

HTH
J.L.

Thanks for the reply again JL.
I don’t think it’s a trigger pad assigning issue. G8 is just the example I used this time. I believe it would do the same if I used G7 or G6 etc. I’d check that but it appears to be an intermittent fault and right now I can’t replicate it. I had to do a forced laptop shutdown with a project open. On restarting everything the problem is gone for now.
I suspect, seeing as Curteye has jumped in and said he’s come across the issue a number of times over the years and can’t work out why either, it is an underlying intermittent fault, the cause of which remains unknown.
I’ll leave it to better more experienced minds then mine to figure out. At the moment I have a work-around it seems!!
Thanks again.