REX files issues within Cubase Pro 8

A huge greeting to the community!

I have a collection of various REX files, and from what I have experienced in the past months with the
latest Cubase (8.0.10), the files click and pop. I have double-checked to be as sure
as possible it is not some plug-in at fault. The clicking happens right between the relatively small slices
that each file has. I have tried adjusting the tempo to the source file original value, yet the same clicking occurs.

I just drag and drop them within the arrange window and this happens. Has anyone else experienced this issue?
If so, do you think it is solvable in any way? Am I missing some settings?

Thank you in advance for your time!

Check your Auto Fades, and set them to Auto Fade In, and Auto Fade Out. In the Inspector on an audio track it’s the symbol that looks like a melting X

@Peakae: Yes, that did it! With a setting of 1 ms works best for me, as the default 10 ms still had a few clicks happening here and there. Thanks a lot for the help, the virtual beer is on me!