Rhythm dot input key on Mac keyboard with numeric keypad

I don’t know if this could be a bug or a simple setup/config issue but …

Using Dorico 2 write mode keyboard entry, I wanted to add a rhythm dot to a note, and instinctively went to the full-stop/period on the numeric keypad section of my full-size Mac keyboard (‘Magic Keyboard with Numeric Keypad - British English’), however this didn’t add a dot.

I then tried the other full-stop/period key, on the main alphabetic section of the keyboard (combined with ‘greater-than’ key), and this worked.

Looking at the Dorico keyboard layout guide in the ‘Key Commands’ help, I interpret that the numeric keypad full-stop/period key that I had initially tried should be correct for adding a rhythm dot … but it robustly doesn’t work for me.

Can anyone confirm or deny? … anyone know it does work, or that I need some simple config setting somewhere?

Regards
Colin

It’s a simple setup/config issue, not a bug.

The number keypad is used in Cubase and Nuendo (yes, Cubase and Nuendo) for transport. The full-stop/period key there is used for returning playback to the beginning. As such, it’s not assigned in Dorico to a rhythmic dot, probably because Steinberg have assumed that many Dorico users will be coming from other Steinberg software (Cubase and/or Nuendo).

Dorico’s default keyboard shortcuts NEVER involve the number keypad, incidentally. The developers clearly recognised that most modern laptops ship without a number keypad; all Macs ship without a number keypad etc. See https://www.steinberg.net/forums/viewtopic.php?t=114525#p625732

Fortunately, assigning it is simple. Go to Edit > Preferences > Key Commands, and then type dot into the search bar, and then click the arrow next to “Note Input” and select “Dotted Notes”. Then click on the text box to the right hand side (where it says Press Shortcut), tap your number keypad “.” Then click “Add Key Command” followed by “Apply” and “Close”

Thanks pianleo. I like the fact that the Dorico key codes are so easily and powerfully configurable.
I’m also impressed that the Dorico default key commands adapts to keyboard type (nicely explained in the Dorico help, introduction, conventions).
Dorico is a class act in so many ways.

I have now added the key mapping, and am grateful for the pointers, and for the capability and flexibility of Dorico.

When I raised this question, I was thinking it surely couldn’t be a bug in such commonly-used functionality, I must be missing something.
However what I realise from this discussion is that firstly the Dorico key command default assignment is automatically tailored according to the type of keyboard that it detects, and secondly that I am quite possibly very much in a minority Dorico user category with the keyboard type that I have.

So … I do now think there is a minor bug-ette here, in either the way Dorico internal help visualises the key command mapping in the on-screen keyboard layout illustration (for this type of keyboard), or the way the Dorico default key command configuration gets set up (for this type of keyboard).
Either way, I suggest there is something here that could usefully be tidied-up/improved by the Dorico team.

I interpret that this issue is very specific to keyboard type, therefore users who have different keyboard types will not be affected.

Thinking back, I have a feeling I had noticed this as a niggle before, and therefore I suspect this issue also existed in Dorico, and has carried forward to Dorico 2.


Summary of key points: (for my keyboard type)
A) I interpret that Dorico now does detect and support keyboard with numeric keypad, and the default key command mapping adapts accordingly.
B) With my computer + keyboard + Dorico 2 setup, the Dorico help shows the numeric keypad is assigned for various key commands, and generally works fine … just not in the case of the dot.
C) The Dorico help nice illustrated key command keyboard layout shows that the numeric keypad dot is assigned for dotted note.
D) But in practice, Dorico default key command mapping hasn’t picked up the dot mapping from numeric keypad, despite having evidently detected the keyboard layout, and assigned other key commands to the numeric keypad, matching the illustrated layout.
E) So … there is an inconsistency between the Dorico help keyboard/command layout view and the actual key command mapping (for this type of keyboard)
(this also appears to show that the help keyboard mapping visualisation isn’t dynamically generated from the actual key command preferences settings, otherwise it would have been consistent)

I don’t know how this compares to the status when the other thread linked above was started in March 2017, but certainly now Dorico does assign default key commands to use the numeric keypad when available.
I don’t think I can attach images here, or I’d include one to show the commands that Dorico says are mapped to the numeric keypad for this keyboard type.


Further notes from my wanderings: (for my keyboard type)

  1. Dorico internal help feature for ‘Key Commands’ shows a nice illustration of keyboard layout (complete with numeric keypad) matching what it has presumably detected as my keyboard type.
    On this layout, in write mode context, it clearly labels keys on the numeric keypad as being for various aspects like note durations, accidentals, and the elusive dot.
    Therefore I interpret that the Dorico team have consciously chosen to detect and support keyboards with numeric keypad, and to select default key command mappings to nicely utilise the numeric keypad.

  2. The other keys on the numeric keypad do appear to all work as illustrated in the help information. I’ve been happily using them for note input, and not yet noticed any other missing functionality.
    However, as I’ve noted, the numeric keypad full-stop/period key, though illustrated in help as being for ‘dotted notes’, does not appear to have been configured to match this in the Dorico default setup.
    Therefore I interpret that the numeric keypad has been selected with by the (cleverly adaptive) default key commands, and are generally working fine … except for the dot.

  3. When I hover the mouse pointer over most of the note entry tools in Dorico, it shows the corresponding key command, however for the dotted notes it doesn’t any such key command (at least in my Dorico 2 installation with my attached keyboard type).
    Yet if I go into the File > Preferences > Key Commands > Note Input > Dotted Notes, I see that it is assigned key command ‘.’.
    Therefore I interpret this matches my observation, that there is a key command assigned (just not the specific one I was expecting), and I would have expected this to be displayed when I hovered the mouse pointer over the dotted note entry tool on screen … however it didn’t.

  4. I then went ahead and assigned ‘Num.’ for dotted notes, and it duly then showed both ‘.’ and ‘Num.’ as the listed key commands.
    Going back into note entry, dot entry from numeric keypad now works as expected.
    I suspect the intention was to include ‘Num.’ in the default key command mappings for dotted note when a numeric keypad is detected, and that it was missed out somehow. Certainly this would be my preference to include it.


    Regards
    Colin

I think you could be interested by this thread : https://www.steinberg.net/forums/viewtopic.php?f=246&t=139155&p=752253#p752253

Marc, that occurred to me too, but the OP is using a British English keyboard so I think that thread’s probably irrelevant.

Back to Colin:

I think basically there’s a bug in the way that the Key Commands help item is generated. Here’s what Dorico generates for me:

As far as I know, these are unchanged default settings, but note how this page is completely oblivious to the fact that I can use the row of numbers above qwertyuiop to type in rhythmic values. Basically, whatever it is that generates this page inadvertently shows all numeric values as being on the number keypad.

As to

I suspect the intention was to include ‘Num.’ in the default key command mappings for dotted note when a numeric keypad is detected, and that it was missed out somehow. Certainly this would be my preference to include it.

no, this was clearly NOT the intention. The intention was to leave this key unused OR perhaps to use it to send playback back to the beginning, in line with other Steinberg applications. Feel free to search the forum; this has come up before.