Rhythmic cues - vertical alignment and completeness

Hi experts. The lower staff here is the “source” of the rhythmic cues in the upper staff. Should I consider this alignment acceptable (I think not)? There are three places in the chart with the same contents, and the alignment is identical. The chart has been open and closed many times over several days so “restart” does not help. And how can I get the last note (first beat of 57) to be part of the cue? The beat was selected when executing the cue.

image

No, the rhythmic alignment’s not acceptable.
As far as Dorico’s concerned, you have two voices at the same rhythmic position so they can’t automatically overlap; one voice gets offset. There doesn’t seem to be an exception made for rhythmic cues, at least at the moment.

You can bypass the behaviour, though. Select just the real notes in the upper staff, either by selecting the passage and then deselecting the cue label, or by selecting a single real note and then using Select More. Then, in Engrave mode, set the Voice Column Index property to 0. In fact, when you turn on the Voice Column index property it will likely default to 0.

Yes! That worked. I am happy that I only had three places to go in and change this parameter.

What about the missing cue note?

If the slash region was already there, the beat wasn’t selected (highlighting a beat of a slash region is not the same thing as highlighting the stave underneath it, which is what you’d need to be able to do).

Select the cue then type Shift-Alt-Right until the note appears in bar 57. You might then need to turn on the “Hide rests around cue” property.

OK there were really some needs here which made this process not so easy, but yes now it works. Thanks.