Rhythmic notation for drumset

I’m creating quick and dirty live drum parts (fro drummers I know well…!) with slash notation and rhythmic notation cut and pasted from bass and horns. My normal process is to paste the notes in the drum part (which are all over the stave), set it to rhythmic slashes and set this to the middle line.
This works exactly as described in Dorico sometimes, but not most of the time. I am creating a slash voice first, although sometimes this also seems unneeded.
Can someone walk me through it?

When you paste pitched material onto a drum staff, Dorico does its best to approximate the staff positions of the pitched material into staff positions on a drum set, as you’ve found. If you show the kit as individual instruments, you can paste onto any one of the instruments in the kit and all of the notes will be conformed to that single instrument, but of course the slashes don’t appear in that presentation, so you then end up pasting onto e.g. the snare drum and then moving those notes to the slash component. None of this is especially satisfactory: the current workflow for putting slashes onto the drum kit is certainly smoother if you enter the rhythms onto the drum kit into the slash component directly, rather than copying and pasting. I hope this is something we’ll be able to improve in future.

Thanks Daniel. Any idea why it works sometimes?

Might be useful if I set out what I’d like…

Paste a single line instrument onto drum set.
Change voice to rhythmic slashes, which puts it all onto one (middle) line.

I’d be interested to see a case where it does anything different to what I outlined in my earlier reply.

I’m hitting a deadline at the mo… but I’ll recreate after.

Even stranger, in the drum layout, rather than a score, I was mostly able to past different pitches (mostly from electric bass) to drum set then select slash voice and all notes moves to the middle line, exactly as I want. However some still won’t go, no matter what I do, including some bars that are identical to others that will go. This might be related to a larger input carat that is as big as the five line staff?
I’ll send project to you by email, because I’m interested in what is occurring.

A possible workaround for this is:

  • add an unused unpitched percussion instrument to your drumkit on the middle line (like a wood block)
  • set the default playing technique for that instrument to use slash noteheads
  • add the same instrument to your project as a single line percussion instrument (can be hidden in print layouts)
  • paste the pitched notes onto the single line staff first, then cut again and paste onto the drum set staff

You don’t get rhythm slashes in a semantic sense, but they look the same, and they’re pretty quick and reliable to produce as far as I can tell.

That’s a good workaround Tubagooba.

Additional question: How do I copy i.e. the snare to a tom in a drum set? I can only select the different drums via up/down arrows in the kit when I’m in input mode. But I can’t paste in that mode.

Probably the only practical way is to change the presentation type to ‘Single instruments’ on the Players page of Layout Options. (Obviously you can return to showing the five-line staff presentation type after you’ve finished copying and pasting.)

Ok, thanks!