Ride Cymbal sound incorrect in Note Performer 3- referred to Forum by Arne Wallander

The Ride Cymbal playback sound in Dorico 2 is incorrect using Note Performer 3.

I have discussed this issue with Arne Wallander and he suggested I add it to the Forum hoping someone from the Dorico 2 team can take a look “under the hood” at the Midi mapping.

This is his response from our last email with permission to quote:

"Well, I can certainly confirm your issue. But the bad news is, I have
absolutely no clue as to why this is happening. There is not much
transparency in how Dorico selects sounds unfortunately, and the
feature is very new, and as far as I can tell, all looks fine in our
percussion mapping. The ride cymbal certainly works if I create a new
score, which suggests that it should work, although it doesn’t in
this particular score no matter what I do. The percussion map does
look fine.

I would personally recommend asking about this on the Dorico forum
instead. You could probably strip down the file to only a few bars of
ride cymbal notes, if you want them to troubleshoot it. Daniel and the
Steinberg people are in a much better position to troubleshoot this,
since they can also see what’s going on behind the hood. I’d like to
help out, but from our end all I can see is that the wrong MIDI note
is being sent from Dorico."

Best regards,
Arne
Wallander Instruments

I set up a new score from scratch, adding players for a Big Band. The Ride Cymbal is not assigned an instrument by default, I have to add it in the Play panel and this is the result:

The score is available from my Dropbox here:

https://www.dropbox.com/s/1tbcuv9yrrzhq70/Ride%20Cymbal%20Test.dorico?dl=0

You can see in this screenshot that there is no instrument assigned to the Ride Cymbal in the NP Percussion map.


There’s something funny going on with this Percussion map, edits won’t stick on certain midi notes… Make a NEW percussion map (see attached) and define only the instruments you need, sticking to the same note numbers (left column) as in NP Drums.

Thanks for helping, now how do I get Dorico and NP to use the replacement Percussion map?

When in PLAY, under the VST Instruments column to the right, click the rightmost (cogwheel) of the 3 small icons. This brings up the settings window, and you replace the NP Drum set map with the one you made.

I created a new NP Drum set map and changed the settings to use the new map. I restarted Dorico 2 just to be sure and when I restarted I get exactly the same China Cymbal sound as usual for the Ride Cymbal. As Mr. Wallander suggested it seems Dorico is sending the wrong midi information for that instrument.

That’s odd… because it works reliably here. Attached is audio from your file with the map replaced…
Ride Cymbal Test (1) - Flow 1.zip (292 KB)

I had to delete the Drum set instrument that was in the original score and create a new one, mapping it to the new replacement Drum map.

AND IT WORKED! Thanks very much for your insight into how all of this works! I have my Ride Cymbal and I am not going crazy!

This is a band-aid to fix the problem however, it works and I’ll continue to use your solution but out of the box it’s still broken. This is something Daniel and his team along with Wallander instruments needs to look into sometime.

Every time I create a Big Band score with this particular set I’ll have to go through and fix it, easy enough (now) but still an extra step.

I did export a Drum Kit I set up and I exported the new Percussion map so it’s easy to just plug those in when I need them.

Thank you very much for your help and patience in showing me how to do what was needed, I really appreciate your help!

I’ve also resolved this for the next maintenance update of NP, by making duplicate ride cymbal entries for high/low in the percussion map.

Arne, that’s great! However, please take a look at the current maps (pix attached)… there’s something odd here…


The ride cymbal isn’t listed in the percussion map editor, because I’ve only mapped it to the “cymbal.ride” instrument, rather than “cymbal.ride.high” or “cymbal.ride.low”, and the “.high”/".low" don’t seem to fallback automatically to the parent sound, or at least not consistently. This will be fixed in the next NP update.

Opera gongs don’t exist in Dorico, so NP’s sounds been given the mapping of the first instrument in the list. There’s no reasoning behind this but it’s just to remind myself and everyone else that the sounds are there, and you can either remap them manually or they will be mapped by us when these instruments are added to Dorico. Sounds that are labelled “Conga (low)”, but aren’t actually a conga, are sounds which lack a Dorico instrument to be mapped to.

The gong isn’t mapped because I failed to find the gong in the instrument list… :neutral_face: It was listed under “L” as in Large gong, so I overlooked it. This will too be fixed in the next update.

I’m confident it will all be sorted in due course, but my point was simply that there are errors in those maps which can be (and should have been) rectified as of now…

Hi ,
the ride cymbal in Note performer 3 issue is still not solved in the new update !
Or any other news I`v overseen?

best from Berlin,
HJB

My understanding is it will be fixed in the next update of NotePerformer, not the 2.1 update of Dorico.

I was also hoping to see an updated NotePerformer yesterday, maybe soon.

Thanks for the quick reply!

Issue with ride cymbal still not fixed with NP 3.1

It’s probably the old percussion map, having been saved with the score.

Try:

  1. Open Play > Percussion Maps… (top menu, visible in Play mode only)

  2. Locate our percussion maps. Those are named “NP Orchestral Percussion” and “NP Drum Set”.

  3. Select these one-by-one, and click “Reset to Library Defaults”.

  4. Close the dialog and see if that works.