Rode NT-USB Mic Not Recognized By Cubase On Mac

Hey, I am having a issue with my new USB mic. I got the Rode NT-USB to be a on-the-go solution after using the Blu Yeti for a year or so. However, it seems that Cubase does not recognise the mic as an input option. It works flawlessly in Garageband so the issue is not with the mic or macbook. Here is the current set-up.

Macbook Pro Retina 2016
Cubase Elements 8

I have done a lot of research, even translating french and german articles to try and solve this problem. However, no steps seem to work.

When connected to the macbook, cubase recognised the mic on start-up as a potential audio device/ASIO driver. It offers it as an option in the audio devices set-up (see attached image) but even when selected I still have no option to set it as an input device. The transport panel does not react to any noise through the mic in any ASIO Driver selections.

I have tried altering the mic to be default audio in/recording device using the Audio Midi setup panel on the macbook, however, this still does not resolve the issue.

I should point out that I have only been a mac user for 3-4 months so if I am doing something stupid then I will hold my hands up!

Any ideas on what I can try? Read about downloading ASIO drivers for the mac but don’t want to make things worse.

Appreciate any help.

All the best

Have you gone into VST connections and created/assigned this input?

Hi, thanks for your help. The mic is now being registered by cubase, and appears to be recording, however now I am getting no sound from the program at all. Other programs (iTunes, google chrome etc) all work and play through the speakers but not cubase…Cancel that report, I have fixed that issue.

Thanks again…I never had to adjust the VST connections on my windows computer so didnt even consider it as an option.

Help I have the same problem with the USB Rode mini. how did you get the problem solved?

I have tried everything and nothing !!