Roland A300 pro & Cubase AI


I am trying to use a Roland A300 pro with Cubase AI and am having real difficulty with the control mapping. I’m also using a Steinberg UR22 for audio connection - not sure if this will be relevant.

I have followed the instructions in the Roland control map guide - I have selected control map 1 on the keyboard (Cubase solo), have added Mackie Control in the device set up and have selected A-Pro 2 as the midi input. (I’ve tried other options such as All Midi Connections - actually makes things worse!)

The functions work (sort of) but there is lots of erratic behaviour. The faders, for example, do move the on-screen faders but also perform a pitch shift, as if the pitch shift joystick is being moved.

The transport buttons work but as you, say, press the record button, the keyboard plays a note, as if a key has been pressed.

The rotary encoders don’t seem to work at all.

All in all, very frustrating and something is very clearly wrong. It can’t be used unless I can sort this.

Can anyone offer any help?

Thank you


Remove the MIDI Port, you are using for controlling, from the All MIDI Inputs in the Studio Setup > MIDI Ports Setup.

Thanks Martin.

I actually solved this problem shortly after making my post on the forum, although this was more luck than judgement.

I selected ‘A-Pro 2’ as the MIDI input in the Mackie Control (as advised in the Roland manual) and then unticked the ‘A-Pro 2’ and ‘A-Pro MIDI IN’ boxes (leaving only the ‘A-Pro 1 option ticked) in the MIDI port set up.

Works perfectly now!

Thanks for your help.

Thanks for the help guys… also do you by chance know why the Roland A300 constantly sends MIDI data when nothing is moving or being played? My “MIDI In Activity” monitor is active enough I have a hard time identifying activity from my other MIDI hardware.

(see post below, this did not work after all)
Okay, I finally figured out how to stop the constant MIDI activity from Roland A-300, it only took a total of 3 hours to figure out.

close all programs
Control Panel / view Icons / click “A-PRO” driver settings / tick Light Load / click OK
then power cycle the Roland

sure wish I had that time back :unamused:

Okay sorry to say, this did not actually stop the constant MIDI activity from Roland A-300. Once I switched back to the Cubase Control Map it started again. Any ideas how to stop the constant MIDI activity from Roland?


Make sure, you don’t use A300 MIDI In port as an input of any Remote Device, please.

Okay, so the resolution was simpler than where I was looking, in order to stop the constant MIDI activity from Roland A-300. Encoder Simulate is assigned to Knobs R1 - R9, so if any of these are not dead center, you will receive continuous MIDI messages that slowly change your individual track pan settings, eventually over time panning those tracks far right/left. I guess I just assumed the knobs would act like the sliders, where you move the slider to a position and your stopping point sticks.


In general, knobs behave the very same way as the sliders. Maybe they are too sensitive on your device and when you are playing and the keyboard is moving, it moves with the knobs a bit.

hey, how did u configured the Knobs, so they work usefull? for me, after setting them to “control change” in the Editor, they are far to sensitive and pan in the wrong direction.