Roland Quad Capture Trouble


I just purchased a new laptop solely for a mobile music workstation.

The specs are -

Lenovo G505s
AMD A10 Quad Core
RAM - 8 GB DDR 3
HDD - 1 TB
Audio Interface - Roland Quad Capture USB

Software - Windows 7 x64, Cubase 7.06 X 64 and Komplete 8

Cubase behaves very badly while using the quad capture… very poor vst performance, random hanging on exit and random hanging on startup. In short, its completely unusable. I’ve tried everything, changing the usb slots, upgrading to latest drivers, changing buffer size, etc. BTW, while using the roland, I disable the onboard soundcard.

On the other hand, if i switch to the generic low latency drivers of the laptops onboard sound (after disabling the roland), these issues all disappear. Cubase runs smoothly, vst performance is twice as good and things go as they should.

The big problem is, I can’t use the laptop’s onboard soundcard for good quality audio recording .

I’d be grateful if anybody here could suggest some way of getting the Quad Capture to work smoothly. I know it is a good piece as it works flawlessly on my earlier system… a much lower configuration Dell Vostro, 3gb ram, 320gb hdd and first gen intel i3.

I have followed all recommended W7 tweaks.


USB2 or 3 port? I wouldn’t disable the onboard sound card, no need.

Hi NWP… thanks for the reply.

I have 1 usb2 and 2 usb3 ports. I have tried plugging it into all 3. There is a marginal performance boost if I use the usb3 ports. However, the random freezing, crashing, etc is constant on all usb ports.


Did you try toggling ASIO Guard? Did you try enabling the onboard SC and restarting system?

I’d say usb2, maybe usb1. I use an Octa-capture with no problem although there is a later driver for Win 8.1, not relevant here but somebody might find it useful and it is cheap to go to Win 8. Could be that the latest drivers don’t cut it with Win7. Not sure if older drivers are available at the Roland sites but if you have downloaded and saved an earlier driver you could try that although I’m not sure that if you’ve upgraded the 1.51 firmware (on mine but could differ to yours) that it would play ball.
Can’t tell if when you tried different usb ports that you reinstalled the quad TO that port or just simply changed the connector. Just tried to see how you could check for (now rare) IRQ conflicts but dammit Win8 seems to have changed the way things are done.
Maybe, if they still do the offers on new lappys, you could go up to Win 8?

Thanks again NWP & Buchanan.

I stumbled upon a strange workaround.

I restarted the laptop with the quad capture plugged in. And it played back a heavy project just fine. But, when i tried to play a vst instrument by MIDI keyboard, there was a lot of latency. Upon checking, I realised that though the sound was being generated from the roland unit, the driver in the device setup was set to the onboard device. Hence, a 40ms latency.

This got me thinking and I downloaded ASIO4all… and lo and behold, i can use cubase now smoothly while using the roland’s audio ins, audio outs and midi ports while specifying asio4all as the device. With ASIO guard switched on, I manage a latency of about 16ms… which is ok by me.

I will use this setting for a few days before jumping for joy… hehehe.


I was going to suggest trying ASIO4ALL, but I see that’s exactly what you did.

That’s what I do any time I have to work with someone else’s interface that may not behave with my laptop (my laptop has a Babyface, but sometimes I need more than two input channels and therefore I need to borrow someone else’s interface.) I have ASIO4ALL permanently installed and it gets along nicely with every piece of hardware. I don’t even bother trying with the original drivers. Except for those from RME.

There’s an article in Sound on Sound magazine that includes advice from Roland following SOS’s less than complimentary earlier review of the Studio Capture in relation to latency. I don’t know if this advice is relevant for the Quad Capture, but I would guess it is.

The default configuration for the Roland driver is to keep the tick box labelled ‘Reduce CPU load’ unticked. This is not enabled because it is better to keep it off when using Cakewalk, which uses the WDM driver and not ASIO driver.

Apparently if you tick this setting, it will not only reduce CPU load but also reduce ASIO driver latency figures significantly. If you haven’t tried this, give it a go.

This is a setting within the Roland driver window, not a Cubase setting.


Got a QUAD-CAPTURE myself. It works fine.
Try to play with the buffer size in the QC settings. I find that setting it on 4 (96 samples) works fine with 44100Hz sample rate. It’s fast enough to not notice latency and large enough that VSTs don’t hiccup.
Try to enable “Reduce CPU load”.

Also, try it with an empty project VS a large project. I had problems with some VSTs that simply didn’t work when having it at 4. For example, Waves L316.

Upon checking, I realised that though the sound was being generated from the roland unit, the driver in the device setup was set to the onboard device.

Was the Roland not there as an option? Because that’s where your trouble lies. I’d suggest going into the BIOS and disable the onboard sound and then reinstall the Roland driver. The Roland driver does also require all usb devices to be unplugged (Cubase dongle too) except for the mouse and kboard.

Thanks again for all the replies!

Plectrumboy & Soul - Burn… I looked in the QC control panel and couldn’t find the “reduce cpu load” tickbox. And, even at a very comfortable buffer setting(7/8), Cubase continues to stutter and crash. It must have something to do with the hardware on my new laptop. As mentioned earlier, the QC works beautifully on my ancient Dell first gen i3 3 gb laptop. In any case, asio4all has solved the problem and I am up and running nice and smooth. :slight_smile:

Buchanan… that is not the problem. I do see the Quad Capture as a device option in the vst devices window. And I did disable all other onboard sound options. Same problem continues. I think my new laptop just doesnt like the QC drivers. Asio4all is a fantastic workaround.

Papi61… yeah the asio4all drivers completely smoothified the system. I’ve been aware of asio4all for years now… just never had the need to use it. Now that I have, I must say it has rescued my life. :slight_smile:


Fair enough. :slight_smile:

I agree that ASIO4ALL is first class software, and I admire your relaxed attitude to not worrying about getting the best from your Quad capture. I have to say if I’d spent that money on an audio interface, and Roland were telling me I could get stable operation at 32 sample buffer size, giving in+out latency of abut 6ms, I’d certainly find out where the ‘reduce cpu load’ tickbox was.


just a quick update… upgrading to cubase 7.5 has fixed all stutters and crashes… my system works like a well oiled machine… vst performance has improved by many a mile… thank you for this awesome update…