Roland RD700 NX and Roland FP-10 midi issues in Cubase Pro 11

Hi All!
I own a Roland RD700NX and a Roland FP-10 and I use Cubase Pro 11 (latest version, just updated).
Th issue is that when I launch Cubase, if I power on my RD700NX, the piano don’t load its operative system and remains in launch screen.
And with the FP-10 I have to power it on after I launch Cubase, instead Cubase don’t receive midi messages…
Any idea?

Hi and welcome to the forum,

I have never heard something like this.

Could you try to add MIDI Monitor, enable even SysEx in the monitor and boot Roland? Does it seems any MIDI Message to Cubase/MIDI Monitor? I’m thinking, if Roland is expecting any answer message from Cubase…

Hi Martin,
thanks for your fast answer but I don’t know MIDI Monitor…
I know a bit of MIDI and SysEx but I never heard about a MIDI Monitor,
is it a function of Cubase?
If it’s so, where can I found?
Thank you so much!

EDIT: Ok I found MIDI Monitor in Cubase, I’ll try today…

So, I’ve added a MIDI Monitor with SysEx enabled on an armed track and I power up my RD… Nothing happens: no messages and no loading of the operative system of my Roland…


In this case, I would try to use even 3rd party MIDI Monitor, like MIDI Monitor on Mac or MIDIO-X on Windows.

Does it really happen only if you run Cubase?

Is RD700 connected via USB?

I’m using Mac and this problem happens only with Cubase…
I use Live and Studio One and I have no problems.
Plus I had Cubase Elements and this issue doesn’t appear…
And yes, RD is connected via USB in a USB Hub.
(I use a Mac mini).


If you are on Mac, use the MIDI Monitor application, please. Try to monitor all MIDI devices there. The only idea I still have is, Cubase sends some message to the RD700, which prevents it to load.

Ok I started Cubase with my RD powered off and when I power it on the MIDI Monitor shows me the devices, in which I think there are the two ports of my RD, but no messages are shown. And the RD remains blocked.
Maybe have I to delete 32 bit Midi dirvers from my Mac? (I’m using Mac OS Big Sur)

EDIT: There are no midi drivers in Library

And if I try to update the firmware of my Roland?

Nope… I’ve updated my firmware to the latest but it doesn’t work…


It sounds really strange. So far I have no (more) idea, what could cause this…

Does RD700 support USB3? Could you try to connect it via USB hub?

Does it work as expected, if you switch the RD700 On first and then start Cubase?

Is RD700 using any VSTi to control it?

I think that the RD700 does not support USB3.
It is already connected via USB hub.
If I power on the piano before starting Cubase, all is ok, but if I’m working and I need to power it off, I have to close and reopen Cubase.
I don’t know if RD700 is using a VSTi control…
I’ve tried to download the latest drivers for Mac ox Big Sur after the update of the OS of my RD but the Mac tells me that the drivers are incompatible…
Even I have no idea…
The fact is that with Cubase Elements 11 all worked well…


What happens, if you don’t do this? Is RD700 hanging while switching it off again?

Could you try in Cubase Safe Start Mode, please?

Did you upgrade your Cubase Elements license to Cubase Pro?

Is your USB-eLicenser plugged in the very same USB hub? If yes, could you try other USB port, please?

yes I upgraded from elements to pro and the elicenser is in the same (and the only) hub that I have…
Ho can I start Cubase in Safe Mode?

Hi again,
I’ve tried to connect the two usb in different hubs and still nothing.
I’ve tried to launch Cubase with the RD powered on and power it off and on again and it don’t start…


Could you try in the Cubase Safe Start Mode [Disable preferences], please?

nothing to do, RD doesn’t start…

EDIT: I have registered my RD700 to the Roland website, maybe it is a pfroblem of theirs, so I create a ticket with the same question.


Great, keep me up to date, please. I’m really curious about this one.

Roland has answered me that the problem is not theirs but of Steinberg Cubase…
I don’t know what can I do…


Do they have any idea, what kind of message or state, could block the instrument to load, please?