Routing audio as a loopback from the audio interface

I want to record audio such as internet radio from inside my laptop on a Cubase audio track or into a VST sampler plugin. How do I route the audio into it? Audacity, for example, offers a variety of inputs including my UR22 interface as a loopback. Surely Cubase can do this simple thing without my needing to connect an audio source into the front panel of the interface.

Hi,

Enable the loopback on your Audio Device, please.

Ah, I hadn’t noticed that in the control panel. I checked it, now there’s a UR22 option in the VST plugin input list, so I expect I’ll be able to sample that way. But when I create a new Audio track, there’s no option for UR22 loopback. How do I enable that?

Hi,

If I’m not mistaken, if you record from any input, you get a mix of the physical input & the output (loopback).

Not from where I’m looking. This seems to be unnecessarily complicated. Audacity, the most popular and open source multitrack recording software around, doesn’t require any setting up: it checks the available ins/outs on startup and provides a handy list on the screen. Clicking the VU meters shows if there’s a signal present on that in/out. I can record loopback with barely a thought.

For Cubase, I’ve looked in the manual, on YouTube tutorials and in this forum and I’m no further forward. Audio from, e.g. internet radio which I can hear and which is recordable in Audacity is not in Cubase. How do I make this happen? I could, obviously, record in Audacity and export it in a file that Cubase or the VST sampler plugin reads. But why can’t I do it directly?

And further: I’ve tried recording into the Cyclone VST sampler plugin but no audio signal is present. You can see from the attached snips the setting in Cubase (with the audio gain turned up in the sampler plugin) - plus one of Audacity with the meters showing the same audio from internet radio. Yet there is an output audio signal from Cubase which can be seen at the bottom right of the snip. I’m very confused.

Even on the phone with Steinberg support, they couldn’t figure out how to get my AXR interface to do loopback in Cubase…

I’m not surprised. I suspect that Cubase is unable to record via loopback - a basic and extremely useful function offered by Audacity for nothing. Shame on you, Steinberg/Yamaha. Prove me wrong!

You need to set your interface as default playback device in your os. So that the signal you want to record appears on the daw channel in dspmix. With the loopback on you should be able to record it on inputs 1 and 2.

The Steinberg interface is the default playback device. Audacity, unlike Cubase, allows users to see a list of recording and playback devices and to choose them. If you examine the two screenshots above, you’ll see that everything is correctly set up: the UR22 is the audio device and it’s working fine in Audacity. In Cubase, the audio appears on the output meters on the bottom right of the screen but not on the input meter of the Cyclone sampler plugin (notice the gain knob is turned up) nor is it appearing on the input meters of Cubase. This should be as simple as falling off a log. Why isn’t it?