Routing instrument track to audio track?

I thought this would be an easy task by right clicking the instrument track and creating an fx track from it or selecting the instrument as the first input in a new audio track but this has got me beat.

Right click the Instrument Track(s) then Add Track > Add Group Channel to Selected Channels.

Then set the resulting Group as an input for your Audio Track.

1 Like

You have to route it from the instrument track to a group track first. And then that to the audio track’s input.

Why can’t an instrument track go straight into an audio track? I don’t know.

Edit: was typing this as the reply above me was posted and didn’t see it.

1 Like

TY Romantique_Tp.

My eyes (and brain) finally found the dialogue.

P.S. I recorded something but I forgot it was an FX track.

I added a group track from the Instrument track but still no audio???

I need a tutorial for this.

I’m used to Reaper atm ,it was easier for routing,that’s for sure.

Just need to understand how Cubase talks.

OK,I GOT IT.

Create a group track from Instrument track,move instrument track and FX track inside Group folder and hit record.

Ok,I’m not getting any audio from the Instrument track to FX track to Audio track anymore,sigh.

I need a tutorial.

I can’t set the resulting group as an input for my audio track.

When I select either the instrument or FX channel in the editing window of the group channel,there is no signal.‘’

I may have to do this in Reaper and bring the stems into Cubase,much easier routing in Reaper.

How do I get the Audio track to see the Midi track output?

This happens in Reaper in Cakewalk.

If I add an Audio track in Cakewalk,I can select the VST Instrument in the Input section then I can print a wav file in real time with the midi.

Reaper does this also.

Been sitting here for an hour trying how to figure out the routing in Cubase.

I will leave it for now.

Example:

  1. Create a group track called “Instrument Group”
  2. From within the Project window, select the instrument track you want to record direct to audio. Open the left zone in the project window and click on the Inspector tab for the instrument track you have selected,
  3. find the ‘Direct routing’ tab in the left zone inspector window and set the direct route of the instrument to the ‘Instrument Group’ in the drop-down list. If the instrument group is not in the list, then you’ve done something wrong.
  4. Create an Audio track and set its input to “Instrument Group”. You do this in the left zone Inspector tab. The first section in the Inspector has a “->]” icon. This is where you select “instrument Group” as the input for the audio track from within the drop-down list.
  5. Set the Audio track to record and play the instrument. it will record direct to audio in real time.

As an alternative you could use Render In Place to ‘covert’ an Instrument Track into an Audio Track without needing to route anything anywhere.

2 Likes

The main question would be, what is the goal of the action?

Not sure what version of Cubase you are using, but CB12 on my system has a bug where selecting the input routing other than Stereo In on a created audio track, displays “No Source” even though a source has been selected and the audio track is still able to record the source. CB 11 does not do this.

This is how I achieve recording an Instrument Track to an Audio Track.

After you have recorded your performance on the instrument track.

  1. right click and add a group track the same way you would add an audio track (give the group track a name).

  2. On the instrument track, press the (e) near the top of the right hand pane (your track overview will open) Near the top of that window where you can select your ins and outs, select the output and from the dropdown list, select the group track you created.

  3. Create your Audio Track. On the Audio Track, press the (e) near the top of the right hand pane (your track overview will open), near the top of that window where you can select your ins and outs, select the input and from the dropdown list, select the group track you created.

  4. Enable record on the audio track and hit record on the transport panel, this will record the instrument track. You will not see sound on the Audio Tracks meter, enabling the monitor function on this Audio Track (speaker icon) will output any sound going to its channel and the meter will show signs of a signal, but it will increase in volume due to your Instrument Track and monitoring through your Audio Track at the same time, but the actual recording level doesn’t increase.

The routing setup is this.
Instrument Track out to the ins of a group track. Audio Track in from the Group Track

If you wish to record with FX, adding FX to the group tracks inserts will accomplish this.

There could be something wrong with your setup?

I didn’t think of this. Could you please give an example as to what could be wrong? As when it comes to my audio’s ins and outs, it is setup identical to my CB11, C10.5 and my CB5 all on the same system and this behaviour is not present in any of them.