Sample Editor ruler not updating on definition manual adjust

Hi all.

I’m curious about this issue because I have honestly done this successfully thousands of times with no trouble, and now I am starting to question my own sanity because C7 is acting weird ever since I updated to 7.04.

I have a drum part that I want to get grid-aligned and tempo-matched and all that.

  1. I record the part in through my audio interface
  2. I open the recorded event in the Sample Editor
  3. I click “Definition” in the inspector
  4. I click “Manual Adjust” in the inspector
  5. I drag the first line right before the first transient in order to “Set grid start”. When I do this, the “1” of the sample editor shifts back and forth as I drag the line around, as expected. Everything is cool thus far.
  6. My grid is set to “1/4” and the default tempo (for this example) is 120. The recorded drum part is around 122. Based on this, when I move my mouse over the audio waveform, I see 3 light-blue lines appear between every two dark blue lines (at 120, so not lined up to my beat). Again, this is expected since I haven’t stretched the grid yet.
  7. I click and drag on one of the dark lines (e.g., beat 1 of bar 5) to line the grid up with my drum beat. NORMALLY, this would compress or expand the distance between each of the blue lines, increasing or decreasing the tempo. However, the sample editor ruler doesn’t change anymore. The tempo updates correctly, but the ruler stays exactly where it is (stuck to the 120 grid). The blue lines (that appear during Manual Adjust) don’t move.

Strangely enough, if I mouse over the audio, I will see the light blue and dark blue bars (with the messages “set beat position” and “stretch grid” appearing respectively) in the correct place, lined up with the audio beat as desired. The problem is that the sample editor ruler, and the associated static blue lines, do not correctly update. It is also worth noting that if I change the project tempo, the sample editor ruler DOES change.

Have I messed up an option somewhere? This used to work, but now it doesn’t. I haven’t seen anything in the manual about this. Nor have I read anything online about it. Does this sound familiar?

Has anyone else experienced this issue?

4 http://i.imgur.com/4xBucAm.jpg
5 http://i.imgur.com/86iQPIL.jpg
6 http://i.imgur.com/Z4lKgfy.jpg
7 http://i.imgur.com/e5OmQpD.jpg
7 http://i.imgur.com/ADopbdm.jpg
7 http://i.imgur.com/5DuSMmG.jpg

I am still having the issue. I thought maybe it was a video card issue so I bought a new video card (windows said my performance was limited by my video card). I thought then that it was a hard drive issue so I bought a new hard drive (SSD) since windows told me me performance was NOW limited by the hard drive. When I got the SSD I did a fresh install of windows 8 and Cubase 7, with a 7.04 update. No other settings changed. Here is a video showing the bug: http://www.youtube.com/watch?v=Gece4G_u44k

Please note that the video has no audio, but that is not necessary. This is a visual bug.

I can confirm the issue. I experience this issue as well in Cubase 7.03.

In Cubase 6.5.3, this is NOT an issue, and the definition grid works as it should. I think it should be reported as a potential bug.

Glad I’m not entirely alone on this. Tech Support told me to try installing 32-bit instead of 64-bit. Haven’t had a chance to do that yet. I don’t see that as a solution to the bug anyways

There are other issues with the sample editor in Cubase 7 as well (the offline process history for example). I’ll eventually collate them, create reproducible steps and post them if they aren’t already reported in the issues forums. Annoying… but eh… that’s why I’m still using Cubase 6.5.3 for my “real” projects. :slight_smile:

Sorry Atlas - I find that video of yours impossible to follow; I’ve no idea what’s wrong, what’s right. So much wild mouse moves… :wink:

Having said that, I tried to follow your recipe, but I am not very good at this and got lost.

The simple message I’m getting here is that doing exactly the same in C6.5.x proves all was perfectly well…! You’ve had good confirmation from Scott (SLD music). Maybe you should now edit this topic title with [ISSUE] and doubly report to SB via a support ticket at the MySteinberg pages. It would appear its more ‘broken behaviour’.

Bob

Switching to 32-bit eliminates the problem. But then I guess I can’t use all 12GB of RAM. Always a tradeoff

I can confirm the sample editor bug on the 64 bit version of Cubase 7.04. Looks like I will have to install the 32 bit version of Cubase 7! :imp:

Bump for visibility.

This bug makes it impossible to set the grid of an imported audio track in time with the project tempo.

Please fix this Steinberg! 64-bit users should not be forgotten!!

Thank you! :smiley:

I think we need to post a repro procedure in the actual “issues” forum to officially report the bug. I will do that eventually, I’m just swamped these days and haven’t had the chance to test a simple repro procedure and then get it written out. I believe the repro procedure can be very simple, and simply stated.

Can anyone confirm whether this bug was fixed in the 64-bit version of the Cubase 7.05 patch?

http://www.pendlebury.biz/using-cubase-6-matching-tempo Following this tutorial will reveal the problem mentioned in this post for 64 bit Cubase users.

Still a problem for on 7.05

Steinberg: Please tell me this is fixed in 7.0.6!!??

It only happens in 64-bit, not 32. I have been using 32-bit ever since I figured out that the problem was with 64 only.

Please Steinberg!!!

This bug is still not fixed in 7.06. :frowning:

Unfortunate, huh?

Guess I have to stick with 32-bit until this gets sorted. :frowning:

To anyone who was expecting this to be fixed in 7.5 (or 7.5.1): it is still broken for me.

7.5.20!!! according to the announcement “It also resolves over 60 issues such as the missing grid for AudioWarp and many more to make your Cubase experience smoother than ever before.”

hurrrrah!!! It sounds dumb, but this is a really big fix for me.

Thanks for posting the issue, I have the same problem and this bug just caused me some hair loss, because the way the software acts I thought I am doing something wrong or there is a new feature that I wasn’t understanding. I am on 7.5.10 (64bit), hard to believe this bug has been around that long, hopefully they will have it fixed on the April 9 update.