Sample editor shows incorrect waveform - Cubase Pro 10.5

Hello folks,
Posting this bug because this has been happening quite often since I upgraded to Cubase Pro 10.5 a few months ago. A lot of times, the placement of waveform in sample editor is different from the actual placement of the file in the project. Attaching a photo to better explain things.
To give you an example, if say an audio file starts at bar 79, when I open it in a sample editor to say quantize it or pitch correct with VariAudio, it is displayed in the editor as starting on 79.3 or 78.4 .(The audio however plays at its correct position at bar 79 as it is displayed in the Project window)
You can imagine that this is especially a problem when trying to quantize it, because of a lack of visual representation of the sample file. I’m assuming this is a bug but it’s been happening a lot. I haven’t been able to replicate the exact conditions to make this happen (or to avoid this happening) but once a file opens this way in the sample editor, it remains like that no matter how many times I shut and restart cubase. Please help! What can I do to avoid this? Cubase pro 10.5 has been quite buggy for me and is really slowing down my work.
Thanks in advance for your help!

Hi,

Dou you have multiple Audio events selected? If yes, and if you cut one of the Audio events, then this is a known issue.

Thank you for your reply! I selected just the one file, although with multiple takes. But even when I removed overlap just now and checked again, it still does misbehaves. This particular case is in a project with tempo and time signature changes, do you think it might have something to do with that?

I found a workaround for this. I just had to flatten any realtime processing that might have been there, set audio events to not be in Musical mode and then finally got to : Audio–>Advanced–> Set definition from tempo.
The grid then seemed to line up. I don’t understand why cubase changes tempo of tracks recorded in that project but it does some times in my case ( Even though I have hitpoint detection off and record in linear mode)

I’ve found a similar bug in Cubase Pro 11. My post is here, along with a link to a video that demonstrates the problem:

https://forums.steinberg.net/t/tempo-track-bug-the-sample-editor-display-goes-out-of-sync-with-the-audio-if-you-cut-time-or-insert-silence-across-tempo-changes/682581

I solved this issue by deleting Cubase preferences.
After my post nobody from Steinberg helped me and I decided to try deleting preferences from my Mac. All was fixed after