Screen flickers during playback on M1 Mac Mini

I just purchased Dorico (came from Finale) and after installation I opened one of the demo scores to see how the program works. I noticed that during playback the screen flickers and it stops when playback is stopped.

Welcome to the forum @brentlevasseur.

Have you tried restarting your computer yet?

For what it’s worth, I noticed this as well. It doesn’t always do this, so I didn’t look into it further - probably a restart of the program or the computer would help.

I don’t think that’s the usual experience. I have an M1 and M2 Mac, and haven’t observed any such problem; and can’t remember it being mentioned here.

As said, do a restart. Also, check what other software you might be running that could affect audio or video.

Do you happen to have an external monitor connected? I had this too with my M1 Pro, but it was not related to playback, but to the presence of contrasting items on screen, which Dorico UI happen to have. With some version of Ventura (or Monterey, I don’t remember) this was fixed.

I have an external monitor (since it’s a Mac Mini), and it sometimes happend with Monterey - I haven’t yet encountered it under Sonoma, but I’ll keep an eye out. @brentlevasseur What version of macOS are you running?

Sonoma 14.1.2 @lucas_r_r Yes I am using a 55" 4k LG Oled display with 60-120hertz refresh. The Mac Mini has no monitor so it needs one by default. Mac OS is set to 60hertz refresh on that display. Also its set at HDR color depth.

Then it must not the same problem I had, since it was patched and not related to playback specifically.

How is the display connected?

I’ve been on an m1 since they came out, and I’ve never experienced this, so something seems rather odd. Have you tried disabling HDR (just spitballing to try and narrow down the scope of the problem)

1 Like

Here is a screen recording showing how the screen flickers during playback.
This is a private youtube video so only the people with this link can view it. Click the Youtube settings to set the screen resolution to 4K 2160p for best results.

HDMI 8K cable

I have seen this myself, Brent. I find it is most likely to happen if I leave Dorico running for a long time, and allow my Mac to sleep and then wake again. If you close and reopen the project, that should fix it.

1 Like

If you’d like me to investigate further, please send me through a Diagnostics Report by going Help > Create Diagnostics Report.

It might help if you have a read of this for any future issues you might want to bring up:

Dorico Diagnostics.zip (705.3 KB)

Daniel
I too am getting screen flicker with Dorico 5.1, a 4k monitor and an M1 mini. Yes the flicker goes away when reopening a project after sleep - but I find this an irksome interruption to my workflow!

Welcome to the forum, Geoff. As I say, we’re aware of the problem but unsure at the moment how to solve it. Sorry for the inconvenience in the meantime.

I’m guessing here, but I’d bet that if you gave us the option to swap the gradient background to a solid color, might solve the issue in the interim. Also, it may have something to do with how LG OLED 4K monitor panels and their AI processes gradient colors. So this might be an OLED panel AI issue, instead of a software issue. Having said that, I think the easiest quick fix would probably be to swap the background gradient to a solid color.

You mean something like this?
Screenshot

1 Like

Ha! Exactly! Cheers!