Scrolling is out of control on Windows

First of all, love the update. Dorico 4 is an absolute banger. Thank you, Daniel and team.

Scrolling and navigating around the write page works very well on my precision track pad as well as my Logitech MX Master. They pretty much work exactly how I’d want. Super smooth. However, when I go to the key editor lower zone or the shiny new play page, I barely touch the touchpad/ mouse wheel and it goes flying in to eternity. Needs to be the newer coded stuff. Scrolling was always solid in Dorico 3.5.

Hopefully someone will be able to take a look in to this?

We’re not doing anything out of the ordinary with the kinetic/inertial scrolling in these interface elements, indeed we’re not overriding any settings at all. Do you have a particularly fast mouse speed defined in System Preferences, perhaps? Or are you on Windows, rather than macOS?

It’s Windows. I have everything set to the slowest speed I can. Like I said, it works just fine in the main write page, which is what is odd to me.

Indeed, the play page and the key editor pane go flying with a little two-finger nudge of the touchpad on my Surface Pro 7 as well. Scrolling by clicking and dragging works perfectly well, though.

1 Like

That’s interesting. We’ll take a closer look at this on Windows.

1 Like

Thanks Daniel!

FWIW, touch in the lower zone key editor doesn’t work either…