SDA download assistant - all files download with .sda-download extension

After much scouring of these forums (thanks for those that have posted before) I’ve finally made some progress with my Steinberg Download Assistant issues and I can actually launch it without it crashing immediately (whoo hoo!)

However, when I try to download anything it now displays the following error at the end of the download: “An error occurred during opening: “Product Name” Please check the download directory for this product or download the product again”
When I browse to the download directory all files appear to be downloaded with .sda-download file extension
I’ve tried resetting the directory and various reboots.
It appears the downloads complete but do not get renamed and finalised.
I cannot double click to open a file.


Does the file size matches the size mentioned in the SDA, please? It means, has it been downloaded completely?

I would double-check the permissions of the given folder.

Looks like the file didn’t finish downloading, you might have had a internet interruption. I would delete these two files and download again, you’ll know it’s complete if the file ends with .exe. Good luck!


Hi both
Yes the file sizes matches the expected filesize and I have tried downloading again (different types of downloads)
I can manually remove the file extension and it runs the file (for example PDFs)
This is managable for individual files but not realistic to do for content sets that include hundreds of files - it is not realistic to rename each and every one of these.