Select Length with Logical Editor

I’ve read the previous post on this subject and they aren’t exactly what I’m trying to do. I need to simply select notes based on a criteria that I’ve specified in length. There’s nothing I can do with them using the logical editor because I want to apply articulations to the selected notes. Can anyone help me figure out how to accomplish this.

Not sure exactly what your question is, nor what post your talking about, but have you acquainted yourself with the Logical Editor and read the manual chapter on it?

Steve: I’m guessing here, but I think Danika wants to know if the Logical Editor is capable of assigning an Expression value to all notes within specified lengths? Something like: Assign Staccato Expression to all notes within >50 ticks< or something like that? Is that it?

Well, if that’s it, Cubase can select with the L.E., and then the user would apply the articulation to the notes. But is the OP using Expression Maps, or just entering controller values directly, or…

Filter pane:
Length | Inside Range | x.x.x.x | x.x.x.x | <-- where x.x.x.x is the low, and high values for the range of lengths.

Action

Function: Select

Yes that’s exactly the question I’m asking. I’m using expression maps and once the notes are selected, I can assign an articulation with the expression map. However, my basic problem is I can’t figure out how to only select the notes. And yes I have read all the information on the logical editor.

Here is the logical editor preset that I defined for this function which doesn’t seem to work for me:

Are there actually notes that are shorter than 0.0.1.84? Can you try a much larger value for Parameter 1? Does anything get selected?

There are 16 notes in this clip that are exactly 0.0.1.84. I did try a larger value but that didn’t work either.

Does anything work in the Logical Editor for you?

Sorry to nag, but it get’s very tiresome to ask people what derivative of Cubase they are using, what OS version they are on, etc. Please. Create a sig with that information.

I’m on Cubase Pro 9.5.0.

I just tested some more, selecting works here regardless of lengths. The only way I could make it not work was by deselecting the part in the project window, and making sure the editor was not front-most.

Is it possible the editor is not front-most, somehow?

Otherwise, try Cubase Cubase Safe Start Mode or hide the prefs form Cubase and give it a try.

I was unable to get Cubase to open in safe start mode so I temporarily deleted the preferences. However, I still can’t get the Logical Editor to select properly (see attached screenshot). Any other suggestions?

Don’t know what to tell you. It works here. By the way the pics don’t show the single needed detail, the note lengths in the info line.

I tried your preset. It works here too, every time (on Cubase Pro 9.5 / Win 10).