Selecting and hiding bar numbers, but not all of them in the same system

I’m looking to solve the following problem. I have orchestral scores (e.g. Ravel’s Boléro) that use condensing and hiding empty staffs intensively.

  • When the orchestra plays with 10+ staves (example left), the bar numbers are shown on the top, on the bottom, and in the middle (e.g. above the drums). I used the Engrave options to do that. That’s fine.
  • When there are very few instruments playing, (example right with four staffs), I get the bar numbers also three times (above, middle, bottom), which is aesthetically and functionally too much.


When I select in bars 8 to 14 (= the second system of the work) the bar numbers in the middle and at the bottom, and I hide them, all bar numbers in bars 8-14 disappear (including the top row).

Is there any means to:

  1. select a series of bar numbers (similar as the functionality of the Select More command, or Filter on bar numbers)?
  2. hide the middle and bottom row bar numbers selectively, while keeping the top row?

Any suggestions are welcome!

You can always select a range of numbers, then edit the Y value to blast them off the page.

I just did a partial row as an example, but it’s easy enough to do entire rows of #s as needed.

Hello Fred,
Thanks, it works indeed :slight_smile: . Setting a negative offset for Bar bumber Y (-500) drops it from the page at the bottom. Setting a positive offset doesn’t work, as the items cannot go above the top of the music frame, apparently.
Any ideas about how to select multiple bar numbers at once (i.e. avoiding to have to click them individually)?

Hmm, either positive or negative offsets work for me, you just have to have a large enough value. You can drag-select multiple numbers at once, but obviously that can be a bit tricky if there’s music in the way.