Sennheiser Momentum 3 Audio Quality

When connected via Bluetooth to Cubasis (latest version on 2020 iPad Pro), the audio quality is akin to listening to AM radio.
I have tried all recommended and suggested fixes, specific startup procedures, and also changing audio resolution, but nothing resolves my issue.
Could you please look into this for me.

Kindest regards.

Hi @schnooker,

Thank you for your message.

Please give the following steps a try:

  • Please connect your AirPods Pro to the iPad
  • Launch Cubasis and go to Setup/Audio and enable “Bluetooth / AirPlay” by tapping the corresponding button

If required, please go to Setup/Project and choose (or reselect) the matching sample rate of your project.

Please let me have your feedback, if this helps to resolve your current problem.

& stay safe,

Dear Lars.

Please read my initial post!
This is now the third time you have replied with the same generic answer.
I have tried all of your suggested troubleshooting options, and none have fixed the problem.

If you can’t fix the issue, or can’t be bothered to at least look into it, then please just throw your hands up and admit you don’t know what to do.

I really am so pissed off with you guys at Steinberg… it’s taken you all so long to release even a useable version of Cubasis, after grabbed our hard earned cash, and now you have no clue on how to assist with a basic Bluetooth issue on headphones.

Just stop with the generic replies, and put a little respect into customers.

Hi @schnooker,

Thank you for your message.
We are sorry to read about your Sennheiser Momentum BT issue.

Be assured that we do take customers issue very seriously and do our best to resolve problems via releasing regular maintenance updates, and provide feedback here in the forum, in the Audiobus forum and through the App Store feedbacks.

The steps description to use Bluetooth devices with Cubasis have worked so far for all cases we know.

Unfortunately we are not equipped with a Sennheiser Momentum 3 ourselves. I will try to get in touch with Sennheiser, to ask them to check the device with Cubasis.

Best wishes,

Hi @schnooker again,

When following the steps stated in my previous post, did you choose the matching sample rate of the project under “Setup/Project” as the final step?

Thanks again,

Thank you, Lars.

I sure did, as I stated in the original post…

Hi @schnooker,

I’ve conctacted Sennheiser through their website, sharing this topic.
Will let you know once I hear back from them.

Best wishes,

Much appreciated, thank you.

Hi @schnooker,

So far I did not hear back from them unfortunately.

Stay safe
& best wishes,

Thank you very much.

“ Hi @schnooker,

Unfortunately I did not hear back from Sennheiser so far, but gave the Bluetooth issue a short check again, using B&O bluetooth phones with Cubasis on the iPad Pro 12.9" 1st Gen, and the latest iPad mini 6th Gen.

It worked fine in both cases to use the BT headphone, following the steps mentioned in my previous messages. Here the most important step, might be to reselect the project sample rate.

Please check the steps shown in the following clip:”

Hello Lars.

No, as stated several times now, changing the sample rate does absolutely nothing to aid in our quest for righteousness; in fact, Cubasis keeps giving me an incorrect sample rate error every time I veer off the only sample rate I can use - I think it’s 44/16, but I could be mistaken.
I appreciate you trying to resolve my issue with non Sennheiser cans, and I’d like to know if you would like me to send you my own, so Steinberg won’t have to spend a dime?

Kindest regards.

Hi :slight_smile:

I made a post about the same issue with Devialet Gemini earbuds, and i found a workaround by launching Cubasis via another app first (Audiobus, AUM, …).

Hope it can help :v:

Thank you so much for your reply.
Unfortunately, Cubasis crashes for me every time it opens in AUM.
I’m also unable to alter any sample rates within Cubasis - without any errors popping up.
I’m definitely thinking the error is with Sennheiser. Strange thing is, Cubasis 2 works like a charm.

Thanks again.

There is another workaround you could try, that i have detailed also, but you have to do it everytime you launch Cubasis (so it can be very annoying anyway) :

#1 : launch Cubasis with the Seinnheiser already connected
#2 : go to Audio Setup and enable Bluetooth / Airplay
#3 open the Bluetooth / Airplay devices list, select the iPhone/iPad , then select the Seinnheiser
#4 make changes to the Buffer Size to select a safe and correct value
#5 load your project again

Then the audio quality should be as expected, in my case this fixes the samplerate to 44.1khz.

To get 48khz i need to launch Cubasis with Audiobus…

I hope this will help :v:

1 Like


Thank you SO much for your consideration and assistance.
I truly, truly appreciate your help.


1 Like