Serious performance issue

Okay - so I’m using a 4-core (8 multithread) i7 CPU with Windows 10 and 32GB Ram - and SSD drives for my VST instruments. Previously, using Windows 7 and Cubase 8, I could load and use tons of VST instruments, like the EW Diamond Orchestra with multiple microphones loaded.

Since upgrading to Windows 10 and Cubase 11 I have serious performance issues. Loading only a few instruments or plugins results in processor overloads and spikes. Often times you see the processor overloading when the system is idle. Hence ASIO guard is suspected. However, delving into those settings - disabling it, turning on - off all possible settings - including multi-processing. Everything other than the default makes the situation even worse - which leads me to suspect that there is some deeper issue with Cubase 11 and Windows 10 - at least my machine - whereby Cubase is not able to access the multiprocessing capabilities of my CPU. When checking the Resource Monitor , however, I see activity on all physical CPUs.

Accordingly I have just performed a control test: loading my VST instruments into Vienna Ensemble Server - and playing the same track that way. Lo and behold, gone are any issues with crackles and pops with the instruments. Now the processor load (and ASIO guard) in Cubase is unaffected by playback - and obviously VEP is not troubled by my machine and is able to playback polyphonically the same load without stressing my processor.


I would recommend to test the system by using Latency on utility.

In general, it’s much better to install clean Windows 10 in comparison to upgrade from older Windows system.

Also as far as I know, the performance is better if you disable ASIO Guard while using Vienna Ensemble, which doesn’t support ASIO Guard.

Thanks for the tip about VEP.

As for the Latency app, I did the test before - and no issues detected. Also I did do a clean install for Windows 10. Nothing was retained from older Windows.

Guess, after all these years, time to actually go over to a competitor’s product. Not that I’m anybody of course, like the pros they wheel out to endorse Steinberg.

Look man, let me be honest with you. Cubase does not handle processing like Reaper does. In 2021 a 4 core processor will max out using a few feather VSTs in Cubase.

Now bringing up VSE server, come on man, I think we both know what the problem is. Cubase does NOT handle processor stress like we all wish it did. I have SIXTEEN cores which max out at 4.5GHZ and still have freaking problems, which is ridiculous.

6 of my cores are maxed while the others are idle. I even split up the massive serial effects onto different groups which helps, but not enough.

1 Like

That as may be - but this is an issue unrelated to VEP - or indeed asking for anything from the processors bar an instance of Play / Kontakt. When I get to 8 instances of Play running a full orchestra, I expect there to start being issues with my machine. This is a complaint because I’m not anywhere close to that.

I’ve stopped using Cubase for now for loading any VSTi. VEP is stable and the results are quite adequate - so far 4 instances. At least comparable to what I’m used to with this machine (prior to updating to Cubase 11).

please try to disable Intel Speed Step (Eist) in Bios. this technology shuts down processors to save power so it’s not really compatible with real time processings