Serious problem with garbled audio playback + crackles

Experiencing real problem with very loud crackling - like radio static almost - along with general audio playback strangeness. Listen to attached audiofile to hear it.

Can’t tell from where it comes or why it starts. Grateful for help in solving this.

Description:

  • It starts and stops with playback. When playback is stopped, it is not heard.
  • It crackles like this for ~2 seconds, then disappears for ~2 seconds and then comes again. Goes on like this.
  • This doesn’t appear when first opening a project. It appears at a later stage, but I fail to pinpoint what may trigger it. Seldom takes longer than 10 minutes before it appears though.
  • If I ignore it (I really can’t, 'cause it’s so loud), and keep playback on for more than ~20 secs, it stops coming in 2 second intervals, and instead crackles on all the time. At this point, the audio playback starts messing up too: in playback mode, the audio tracks start playing chopped up bits and pieces of themselves from all over the track’s duration. Often it gets stuck playing the same 1-2 second phrase over and over, but not always.
  • If I mute all tracks, and hit play, the crackle is still heard.
  • The crackle doesn’t show up on any level meter, though it’s loud. And if the audio starts messing up too (see above) then the level meters will not show the peaks you actually hear (the chopped up looped, garbled audio), but instead they will move in correspondence to what you know is actually on that track.
  • The crackle stays relatively constant but sometimes it steps up very much in volume.
  • I don’t think this is a plugin. I’ve muted all tracks and emptied out plugins on all tracks, one at a time.
  • CPU and Disk meter shows normal.
  • CPU, RAM, Disk load and jbridged applications show normal load in Windows task manager.
  • I have no plugins in trial mode.
  • If I save project and restart Cubase, all works fine again - for a random number of minutes before it starts again.
  • This happens in all three projects I got in Cubase so far.
  • The crackles seems all to be 2 samples long -1 polaritiy glitches.
  • The disk load meter shows 0% load for this project. But when the above starts to happen, the disk load meter starts “blinking” 100% disk load once every second (or so). In other words: the meter shows 0%, but start quickly jumping up to 100% load - for 1/50 of a second or so - and then jumps down 0% again. This repeats, about every second. The disk load meter keeps blinking like that when project is stopped too. I had great trouble exporting the audio clip (above^) because the export process was interrupted a dozen times, telling me ‘a disk overload occurred during exporting’.
  • This is on Cubase Artist 8.0.20 x64 purchased a few days ago. Normal install, on a pretty fresh Win 8.0 Pro x64 installation. Computer is up to modern specs, all win updates installed. I installed 8.0.10 first and then immediately applied the 8.0.20 update.
  • I have plenty of experience in configuring/optimizing systems for recording setup, and cannot recall any mistakes this time. Plugins are all on C:\program files\vstplugins and all audio is read from a non-system SSD drive. Both system and non-system SSD disk read/write capabilities and speed checks out fine in disk maintenance utility

Anyone plz got any idea what on earth this could be?
Thanks in advance
PS. Sorry 'bout the lame guitarplaying in the audio file. It was a quick experiment. :wink: .DS

Have you tried increasing the buffer size?

Buffer size and setting up your system for audio performance.

Have you taken such steps?

Those crackles and pops are signs that your PC is having issue keeping up with the audio streaming. Changing settings can and will help. Though you have to set it up correctly to do what you want it to.

Sorry, I can’t upload your sample as I have a deep aversion to downloading anything Mac based. Just bad luck using Quicktime Or Itunes on my PC systems…

I thought that Windows 8.1 was the latest. Don’t know as I am a W7 user still.

Here is a kind of a general system setup guide. http://www.sweetwater.com/sweetcare/articles/pc-optimization-guide-for-windows-8/

Thanks for input so far.

Though, I’m not so sure it’s the buffer size. I would be sure that buffer size wasn’t the cause, if it wasn’t for Steinbergs ASIO guard. I’m not familiar with the details of that one - yet.

A too low buffer size would show up on the performance meter as alarmingly high CPU usage, or high disk usage, or both. Also, the crackling wouldn’t be strictly periodic like it is now, and it would increase when more instruments are playing at the same time. It doesn’t.
Windows task manager confirms Cubase performance meter output: CPU load is fairly steady at ~30-35%, and disk load is ~4-5mb/s (using an SSD, top read speed of over 400mb/s).

I got my audio interface buffer size set to 1024, with ASIO guard set to “high”, giving me ~105ms latency (compensated). No matter what I set the buffer size to, I get roughly 105ms latency with ASIO guard on high. Not sure if this is the smartest modus operandi, but it seems too farfetched to be the cause of all the above.

About the optimizations in the link, Jimmy, I got them all done, and set Cubase to use that Steinberg power scheme. Only one of those optimizations I have not done, is to disable C-state transition and turbo boost in BIOS. I don’t think I got those as options on this machine, and it couldn’t possibly be the problem anyway. I’ve been running 4 DAWs on this system with no problems relating to performance or soundcard interaction.

And yes, Windows 8.1 is the latest, but … I don’t care :stuck_out_tongue: Still on 8.0, and I keep hearing 8.1 is real finicky about drivers, rendering some perfectly good components almost useless.

If ur gonna use windows 8, use 8.1…


(Now for some post-crash humor):
Cubase is how it “should be” . all other manufacturers - hardware and software have it wrong.
You have a 100,000$ computer with enough power to run the world? Its finely tuned by the gods of IT?
Every other daw/program runs smoothly and without a hitch?

Well everybody is wrong, because cubase is the only one that has it right. Fix your system.

Might look into 8.1 soon. Got my behind full of other problemsolving right now.

Not sure if the rest of the post was ironic or not. But … assuming so, yes, in the Steinberg sphere, ppl don’t talk exact details, processing components and processing orders; don’t find out what the exact detail of a problem is.
Instead it’s always “did you optimize your system?” or “Must be a badly programmed plugin” or somehow things are just blamed on abstract nonspecific things or user error. Even the official support does that, almost insinuating Cubase can’t be blamed, while it actually is surpassed in stability and processing efficiency by several generations.

I noticed that closing my Kontakt GUI crashes Cubase. Support said “Did I optimize my system?” and continued focused on finding some blame on Kontakt, while Native Instruments had already confirmed that Cubase 8 graphical processing crashes when closing Kontakt GUI, something which never has occurred on any other DAW before.

I’ll see if I can find out what causes this problem of mine, figure out some home-brew ugly-hack. Can’t help but missing Reaper already. 4 days after installing Cubase, production is still halted, due to faultfinding of unknown problem, without a map. Reaper folks are laughing at me on their forum :confused:

Hey man-used to experience this sort of stuff all the time when I didn’t have source + slaves all at the same clock speed. This problem SCREAMS clocking discrepancy to me. Double check your audio interface, slave computers, samples, etc. are all at 44.1 or 48 or whatever you’re writing at. :slight_smile:

Sounds like a clocking issue.

Yeah, it could very well have been. Unfortunately, I’m not running any outboard gear. I’m running at 48 and if the fault isn’t using 44.1 samples in a 48 project, it can’t be the explanation.

When these crackles start, the volume meter on the Master out channel freezes, in max output reading. And any plugins on the master output (I got my own meter plugin on the master out, Zplane PPMulator) starts acting extremely strange too. It starts showing letters inside of the meter value slots, and the numeric level values turns into a static readout of “-1.#L…”. This must mean that whatever is causing this crackling must be sending digital information through some sort if channel and can be received by other plugins, or at least affects them to perform other things than their normal operations.

It’s a mystery wrapped in a riddle inside an enigma.

Sounds pretty apocalyptic to me…
Must…resist…citing…silly…Cyberpunk/Matrix one-liners… :smiley:
But seriously: What about a complete system wipe, and start from scratch?

And: Fixed it for ya! (couldn’t resist after all…)

:smiling_imp: :sunglasses: :wink:

Benji

Have you tried loading Cubase in Safe Mode and testing??

You should put your system specs in your auto-signature as well.

sounds like you have a plug running in “demo mode”

I had the same thing happen to me when I was on fl studio. sorry man but the root cause of your problem is jbridge.

I already replied to your other thread, you may want to look into a different reverb plugin. bridging anything under jbridge will likely have some unexpected results like the one posted at the top of this thread and it’s a lot less stable. this is why I opted for cubase instead of ableton live when I bought cubase (ableton was my other option, and out of the two, cubase has a native bridge wherease ableton just uses a ported version of jbridge)

I would recommend replacing all of your 32 bit plugins which use complicated user interfaces with 64 bit versions if you can or find acceptable replacements that work in native 64 bit. the less complicated the user interface, the less likely you’ll have problems so plugins such as the classic chorus, flanger, phaser etc seem to work okay in cubase 64 even though they are 32 bit under cubase’s bridge.

thing to remember is that if you load up ANY bridged plugin, the bridge itself will eat up cpu in ADDITION to the plugin itself. and anything you do with it in the daw.

Just did a super clean install of Win 8.1 Pro, on two different computers here. Both with different and excellent specs. This crackling is back, and no 32-bit plugin is used in the test-projects so far. This happens on both computers.

So far, the more I try, the more it seems to encircle Cubase … somehow …
And that’s besides the fact that I’ve never encountered this phenomenon in any other DAW, regardless of what plugins are used.

Unique to Cubase is also that there’s no way of searching out where it is actually coming from. You just gotta fumble around, blind in the dark, trying hundreds of unknown factors/combinations, hoping for the best. And if it disappears, is it just temporary? There’s no way to tell, because there’s no way of finding out where it’s actually coming from.

This is so disappointing …

well there are more users experiencing no problems than not. if it follows on 2 clean computers i would be inclined to start looking at other common elements first like soundcard, lack of soundcard (asio4all). the chances of cubase exhibiting the same symptoms on 2 different systems would suggest cubase as the culprit but it runs fine on 95% + systems that are configured correctly with adequate hardware.

+1

Start from square one. It seems obvious to me now that there is something other than Cubase that is causing this issue for you.

Eliminate what the possibilities are.

Mic>preamp/interface>driver>setup>etc…

Wait, I don’t even recall reading what audio interface you are using…

Really, lots of people are trying to help here, but how can they if you don’t post your specs in any detail? Sound interface, plugins you are using. You should post a detailed list. Hardware and software. Cmaffia is right - it SOUNDS ike a clocking issue. Are you using any digital inputs or outputs such as adat or spdif? Are you using inserts on the master output? Ditch them, save the project with a new name and try reloading. How many tracks are you running? What kind? Is your project mostly Kontakt based? If so have you personally been in touch with NI support?

Cubase is

surpassed in stability and processing efficiency by several generations

Where on earth did that pearl of wisdom come from? I guess we’ll have to explain this to the thousands of professionals who use Cubase every day to make a living. :open_mouth:

I actually agree with this statement and the fact that thousands of users are using Cubase for a living does not contradict it in any way.
Did you ever see any other DAW, or even any other version of Cubase for that matter, with so many instability issues as Cubase 8?
Why do you think they’re messing with the ASIO Guard? Because they know that they need to keep up. Or do you think that Steinberg will ever give you more features than they absolutely have to in order to keep the ball rolling?
Just look at the list of Cubase8 new features.

Anyway, if you want to see it, you will. If not, it’s all good.

My last post has been silently deleted and, since I was touching on the same subject, I wonder if this one makes it through the barricades :slight_smile:
Oh well, it does not really matter.

Kind of funny because plenty of professionals will tell you the OTHER software of choice is riddled with bugs but they are living with it AND are making a living with it…