Serious problems with external gear as inserts

I’m on Wavelab 10.0.60.
I’m having serious latency issues when using external gear as inserts in Wavelab. Windows 10, RME Fireface 802. Haven’t tried this with another audio interface/converter yet. I haven’t tried this with previous versions of Wavelab.
External gear inserts work perfectly without any latency or stability issues in Cubase.

→ Playback latency. I press the play button and I have to wait about a second to start.
→ Playback difference between what I see (timeline needle/waveform) and what I listen
→ Big latency between external gear metering and playback through Wavelab. It’s really annoying, not even sure what’s going on there.
→ Wavelab feels unstable in general as soon as I insert external gear no matter if it’s on clip, track (montage) or master section.
→ Short noises occur after I press the play button. These noises also occur in rendered audio.

Tried different buffer size settings and sample rates. No difference.
Sample rate/digital syncing has nothing to do with it since I even disconnected any digital device to be sure it has nothing to do with that.

Did you try without other plugins? External Gear plugins side to side with other plugins that have latency, increase the overall latency more than linearly

Yes I did! First thing I inserted was external gear and the plugins after. Didn’t notice if there was bigger difference with or without plugins but latency starts immediately with external gear.

Forgot to mention that external gear insert also causes short noises after I press the play button. The problem is that these noises also occur in the rendered audio.

1 Like

What is your audio device block size? Don’t use less than 128 in 44.1k of 256 in 96k.

Ok, I’m usually on 512 though. As I wrote in my post tried lowering or increasing buffer size (up to 2048) but it doesn’t make any difference.