Set Timecode at Cursor doesn’t accurately set the start of the frame at the cursor


When using 29.97 frame rate. Nudge 1 Frame forward versus 1 Frame back are a different number of ticks. How is that possible?

Set frame rate to 29.97. Then set barline 5 to be 1 hour in timecode. Then puts cursor at barline 5. Then uses the nudge command to nudge back one frame, and then nudge forward one frame. Should end back at barline 5, but doesn’t, it ends up 7 ticks past barline 5. Anyone have any idea how nudging a frame back is a different distance than nudging a frame forward? It’s like some weird Einstein relativity paradox.

Also, if I switch the digital timecode to seconds, it shows 1 hour 3, seconds and 600 milliseconds at bar 5. But timecode says exactly 1 hour. Crazy.


Is your project frame rate set to non drop frame? That could explain the difference between timecode and real time.


No, it is not drop frame. Also, my friend on Nuendo 11 has the same problem and gets the exact same numerical error.

First set key commands for nudge +1 Frame and nudge -1 Frame

  1. Set time code to 29.97
  2. Move cursor to barline 5
  3. Command “Set Time Code At Cursor” to be 01:00:00:00"
  4. Timecode now reads 01:00:00:00 and bars/beat will read
  5. Now use key commands to nudge back one frame and then forward 1 frame

6 Weirdly you do not return to your starting point, but instead

Maybe the video frame isn’t exactly on bar 5. Even though you set the timecode to start there. When you nudge by frame it might be quantized to nearest video frame.


You don’t even need to put a real video in to test this, so there is no actual video frame to cause that. Just follow the steps above without a video. I believe Cubase is suppose to be able to align a time code point to a specific bar line? I think this is a bug.

P.S. The same exact behavior is available in both Nuendo 11 and Cubase 11

Yes, you are right.
I get this when I try to set the timecode at bar 5.
So the nudge 1 frame works correctly. It’s the timecode that’s not what you set it.

What does your timecode digital display show when the cursor is at bar 5?

It shows this:

Which looks correct but is clearly offset from the ruler. Nudging works related to the ruler. So that’s probably why you cannot get back to exact beat position by nudging 1 frame. Don’t know if it is bug or by design.

Thanks. So definitely a bug.

Same problem with 23.976.

I think the bug is that either the ruler or display is using is using 24 or 30 and the other is using 29.97 or 23.976. I can’t tell which… because my brain hurts.

Well, it happens also at other frame rates. I would say all. The ruler in project window always starts from whole frame. When you set timecode at cursor at certain beat position it is very likely it will not fall on whole frame. I think Cubase counts the offset from the ruler.

It works as you would expect using 24 and 30 though, so there the ruler and display line up.

What’s your BPM? I tried with 30 fps and 120BPM and it worked. But as soon as the tempo is different even this frame rate doesn’t line up with beats and bars.

yeah, you are right. I was trying at 120. Just tried 117 and it doesn’t work.


To me it looks like rounding error.


In fact, the start position (bar 5) doesn’t fit to any frame, I would say. The start position is not snapped to the frames. Once you Nudge, then the new position is snapped to the frame(s). Then you Nudge back and the new position is finally snapped.

@Martin.Jirsak Yes, I agree. The Set Time Code At Cursor seems to not be setting the beginning of the first frame at the cursor, and it ends up somewhere in the middle of a frame instead.

My friend discovered new information. If you do Set Time Code At Cursor at the beginning of the FIRST BAR in a project, then this works for all tempos and frame rates. The first frame exactly lines up right on the bar line. This works even if you do a project offset and the first bar in the project is set to bar 5.

Thus, Set Time Code at Cursor only exactly works to line up the first frame at one place in your project which is the First Bar.

If you do Set Time Code At Cursor at any other point in your project, then it will only line up with a resolution of seconds and the frames will not line up.

This is most likely happening because, under the covers, Cubase is always lining up frames from the first bar.

1 Like

That’s not correct, and it’s not even possible.


With a 24 frames per second framerate, one measure at 60 bpm is 4 seconds long, and 96 frames. At 61 bpm, one measure has a duration of only 3.934 seconds. But 96 frames still has a duration of 4 seconds.


I think you are talking about something else, can you further explain what you are describing.

We are talking about lining up two rulers at a single point on each ruler.

If you are simply saying that 00:00:00:00 timecode will line up with a single barline of bar 1, of course it will. What’s the question or problem?