Setting up AKAI MPK49 in Cubase 12 (Mac)

Hi there,

Just wondering if anyone has set up AKAI MPK49 in Cubase 12(macOS - Catalina). Cubase detects all the ports properly (see attached snapshot) but when I want to map it in MIDI remote it doesn’t detects the knobs, faders, pads and buttons.

I have tried cubase and generic preset on the keyboard but nothings changed. Also tried all input and output ports and just AKAI MPK49 PORT 3 came up in MIDI remote manager as input without any output port (despite I selected one of two output ports before starting mapping. (This forum doesn’t let me upload the relevant snapshot.)

The keyboard itself is functioning well in terms of playing the VST sounds and the only issue is mapping the knobs, faders & etc.

I really hope someone can resolve this for me.

Cheers.


That’s the screenshot I couldn’t upload on previous post.

Hi,

Id the Port 3 the one, where is AKAI sending the MIDI data from the encoders?

Hi Martin, I have tried the other two ports but they didn’t even come up in Midi Remote Manager. See below snapshots:

Hi,

  • Add a MIDI Track.
  • Set the MIDI Input to the Akai MPK49 Port 3.
  • Move the knob/fader.
    → Does the MIDI Track receives the MIDI data?

  • Set the MIDI Input to the Akai MPK49 (1).
  • Move the knob/fader.
    → Does the MIDI Track receives the MIDI data?

  • Set the MIDI Input to the Akai MPK49 (2).
  • Move the knob/fader.
    → Does the MIDI Track receives the MIDI data?

This is the way, to find the MIDI Port.

Is any of the MIDI Input port assigned to the Track Quick Controls or VST Quick Controls by any chance?

MIDI track just receives the MIDI data from the first port. The second one is sending the notes and still not sure about the third one which is the only one MIDI mapper accepts.

In Halion Sonic plugin all the knobs are panning and all the faders are changing the volume level similar to each other.

With regards to quick controls, not sure how I can assign any ports in Cubase 12 prior to midi mapping.

Thanks.

Hi,

Then you should use the 1st MIDI Port.

Now the question is, why you don’t see it. As I said, maybe it’s in use for the Quick Controls?

Thanks Martin. How can I check it? Sorry if I seem to be a bit dumb. Pretty novice with cubase.

Hi,

Open Studio > Studio Setup > Track Quick Control and check the MIDI Input and MIDI Output ports. Do the same for the VST Quick Controls.

Nothing was connected, but the interesting thing is when I setup the MIDI ports there, in learn mode Cubase detects the MIDI channel and address easily for knobs and faders. I really don’t know why it doesn’t work in MIDI remote though.

Anyone else has any ideas about how it could be resolved?

Sorry I can’t help, but I have exactly the same problem with my Akai MPK249.

Cubase 12 doesn’t see port A in the midi remote set up.
If I select port B and configure the Akai to send controller data on port B I can add the controllers and Cubase sees them moving, but assigning a parameter to them doesn’t do anything.

I previously had everything working in Cubase 11 via generic remote, but now nothing works.

I feel like I’ve paid an upgrade price for a downgrade.

That’s really disappointing Julian; but I still hope someone can help us.

Yea if anyone can provide scripts for the mpk series to work fully would be fantastic

Hey folks, I’ve got my MPK49 working… apart from the transport buttons which only work once and then stop working, but I can now configure everything else perfectly.

There’s a catch though… it still refuses to work if the Akai is plugged directly into the computer.
But if I connect it into the USB in of my Apogee Quartet audio interface, Cubase recognises it as ‘Quartet’ instead of MPK49, and then it works.

I don’t know why it works now, or why it doesn’t when connected directly, but maybe if your audio interface has a MIDI input you might be able to replicate my success.

That’s a good news Julian. What OS are you using? Windows or Mac?

I’m on an iMac Pro running OSX Big Sur.
I don’t think this issue is OS related though. I maybe wrong of course, but it just doesn’t make sense why the Akai is visible everywhere in Cubase 12 except the new MIDI remote feature.