Setting Up My MIDI Controller

Hi everyone,

I have 2 questions about my MIDI Controller, I hope someone could help me on this.
I use Cubase 11 Pro and KORG NanoKontrol2 as MIDI Controller.

  1. I wanted to use “Transport Controls” like "Start-Stop-Record…"etc and I programmed them accordingly.

But I realized that the “Record” button on my Controller does not work exactly the same way with my computer’s keyboard’s space button. The issue is; when I use space while recording sth; Retrospective Record option is available. But if I use my Controller, the retrospective record button is not active and I can not use it.
I also see the CC value as a MIDI note in my track’s MIDI data.

-How can I programme the Controller Button exactly the same as the space on the keyboard, that gives me the retrospective record option?

-I would like the controller’s record button not to record any MIDI data in the project. Is it possible?

2) I have tried to swith on the lights of these Transport Buttons on my Controller but I could not do that. Does anyone have any idea on this?

Thx in advance.

By default the Space Bar is bound to:

In case you’ve changed this at some point, and also for future reference when you’re trying to figure out where things are in all those menus to bind an event for…

  1. Open Edit/Key Commands in the main Cubase menu.

  2. Click the field where it says “Type in Key:”

  3. Tap your space bar.

  4. Click the ←Select button. This should highlight in the top left pane whatever command you have bound to the space bar.

  5. Scroll up so you can see what Category/Folder the command is in. This is what you’ll want to find in the Generic Remote to bind the event from your record button for.

  6. Go to your Generic Remote and bind it.

Just to pick up these other two questions for you :-

Just untick the device from being part of the ‘ALL MIDI’ group, in the MIDI Port setup table:-

You can still select it manually on a track, but by default it won’t play through.

On the flags, tick “Transmit” option and the signal will be sent back to your controller.

Thank you so much @Brian_Roland for your help. It is gonna be so easy to programme other functions with this manner :pray:

Thank you so much, “In all MIDI” thing is OK now.

But the Controller’s lights still does not working.
I have watched some videos, but they were for other DAW’s. I could not figure it out.

I just want to see lights on all the time the PC is running.
Is it possible?
It is maybe from the Korg Kontrol Editor but I could not do it…

It depends on how the controller is setup, some buttons send different state messages i.e. 0 when off, 127 when on. You may need to change what kind of button mode is in use too, as per the lower flag settings (Toggle/Push):-

I’ve also highlighted the MIDI output port as well - make sure that is sending to your Nano too! (Even though mine says ‘not connected’ sorry lol)

If the button is not set to be toggle mode on your controller, then the light won’t stay on - So change them in your Kontrol editor:-

Also, ensure that your controls are set to external LED mode in the Korg Kontrol Editor software:-

I have tried it for one button (play) for trial.

I think there must be sth I am missing.
When I do these, there is no light, and also play button does not work properly…
Could it be “Assign type” or sth like “Off Value” ?

I think you’re best to set it to send CC values of 0 and 127 for the off and on state, not a note. (If you change this, remember to highlight that control in Cubase and ‘learn’ the new value.)

And did you set the LED Mode to ‘External?’

You also need to set to “Transmit” flag in the upper area in Cubase so that “R,T” are shown.

Yeah, the LED Mode is External.

I could not figure out why this is not working :confused:

You’re not going to like this! :slight_smile:

I just got my Nano from laptop bag and spent 30 minutes trying to get it to work - it seems as though something happens that cancels the light out when they’re set to receive and send, even though all appears to be set up correctly.

I don’t know if it’s a Cubase or Korg issue, though.


There is a fix, but it involves create a separate Receive entry, and a separate Transmit entry, see here:-

If you look at my screenshot you can see i’ve doubled up the maps and had an IN (Receive flag) and an OUT (Transmit flag) for each control.

In Korg editor, set them to be momentary and 0 and 127 on and off values.

Then in the mappings, you have duplicate what they’re doing, and what is coming back. IN items set to P (Press / Momentary), and OUT items set to be Toggle.

Then it all works fine, i’ve done it with all the transport commands and they respond if I use a mouse, or the controller - so stay in sync brilliantly.

What’s going on is that when you press a button it sends a 127 value, and then cubase will send a 0 or 127 back to set the light on or off. It’s the only way I could get this to work.

Let me know how you get on, sorry it’s so complicated… I have Studio One here too, I may try it with that and see if this is a Cubase or Korg issue! :frowning:

Of course, a really handy bonus of mapping in this way is that you can have the button operate a function, and the light it produces could be of whatever you choose. Which is handy if you’re using commands to trigger playback, and not the standard transport controls.

I really hope this makes sense!


Yes exactly - for the PLAY button I’ve also had to set up separate send and receive entries in the Generic remote to make the lights behave properly with entirely different controllers (a few different one’s from Native Instruments).

If you have multiple pages, that must be a right pain. Although I suppose you only have to double map where there is light feedback.

Trouble is on those Nanokontrols you have 8x Solo, Mute and Record buttons!! :slight_smile:

Any idea what causes it? It seems that if you map two buttons the same in the ‘standard’ procedure the button that you haven’t pressed seems to light up, whereas the other doesn’t. Which makes me wonder if the transmit message is being sent too early or something(?!). It’s being cancelled out with the press somewhere.

I don’t have to do the separate transmit and receive on other buttons.

On my NI controllers, I have to ensure that the hardware controller button is in Toggle mode, rather than “Trigger” or Gate".

If it’s in Trigger or Gate mode, I have to configure the LED to react to incoming midi, rather than to the internal button press.

Not sure, if you have maybe similar settings for the Korg controller?

I have tried it, of course it made sense, my friend! I don’t know what to say!

Thank you so much for your time and effort :pray:
This should not be that much hard to just switching the lights on :smiley:
KORG should consider to improve sth on this :wink:


As my dad would often say “çok güzel!” :slight_smile:

Glad it made sense, if you get stuck again, I’m sure one of us will find the answer hehe.

1 Like

Really appreciate your effort and also this little Turkish detail :slight_smile: