Setting UP TASCAM US 2400 in Cubase 10

I’ve used my trusty old TASCAM US 2400 in many past iterations of Cubase and, having upgraded my computer and Cubase at the same time, am trying to add the 2400 into Cubase 10 as the controller. However, I am unable to locate where to select the Mackie Control devices to add them to the appropriate MIDI ports. Do I need to create the Mackie device now or is it in a different location?
Any advice or direction would be greatly appreciated!!

Thanks!
John

Hi,

It’s in Studio > Studio Setup.


I’ve got 2 2400’s connected in C10 with W10x64. Studio/Setup etc etc

Hi,

Oh that’s nice! :slight_smile:

Hi Martin,
Thanks for the reply. Sorry for the slow follow up, I’ve been traveling.
I am familiar with the Studio > Studio Setup screen. The TASCAM 2400 appears in MIDI channels 2 - 6 and 1 unassigned channel. However, the unit is not responding. That is why I thought I would still need to assign the Mackie generic control devices to the 2400.
Does this still need to be done in 10.5? If so, that is what I am at a loss about.
If this does not need to be done, do you have any ideas why the 2400 is not responding?

Thank you in advance for any direction and assistance.

Hi,

What exactly do you mean by “The TASCAM 2400 appears in MIDI channels 2 - 6 and 1 unassigned channel.”, please? Could you attach some screenshots?

No, you don’t need Generic Remote Device.

Hi Martin,
I’ve attached a screenshot of the Studio Setup screen for you.
In the past I’ve always had to assign the Mackie “control device” to the MIDI channels and set the US2400 for Mackie control in order for it to connect in Cubase. That’s why I was asking about the “generic” control devices.

Thanks!
John

Hi,

I would strongly recommend to disable all US2400 MIDI Ports from the “All Inputs” column in the MIDI Setup. If you work keep it enabled, you would send the controlling MIDI data to your MIDI/Instrument tracks.

Moreover, I can’t see any Mackie Control Device in the Remote Devices folder here.

Thanks Martin, I will disable those MIDI ports.
Unfortunately that does not solve the problem of the US2400 functionality in C10.5.
Perhaps I’ll private message Sorinv since he is running 2 US2400 in C10.

Do you have any other ideas as to why it doesn’t work?

Hi,

Yes, this doesn’t solve the usage.

You definitely have to add 3 Mackie Control Devices to the Remote Control area in the Studio Setup.

Hi, I don’t know if I can be so helpful (I have a totally different configuration because of the 2 Tascams). But I’ll try.
First, from midi port setup disable the tascam’s 5 and 6 midi ins and outs (they’re useless). Let the midi 1,2,3 and 4 ins and outs ENABLED (fig 1). If you want to assign a zoom in/out function for the joystick and fkey+null buttons, create a Generic Remote, see the 2nd fig. It’s only for the midi 4 port of Tascam. Then you must create three mackie control devices in Remote Devices setup for the 1, 2 and 3 ports of Tascam (see fig 3). If you want to use the 6 aux buttons, see the fig 3 and use the learn function to create a xml file.

Hope it helps,
Sorin V



Hi,

You are using Direct MIDI and Windows MIDI MIDI drivers. These are doubled, so it might be, the data are doubled in Cubase.

Thank you Martin and Sorin!
I finally got it figured out. It was part user error and part duplication.
However, Sorin I will try making your suggested changes to add the AUX button functionality.
Thank you both again, your assistance and patience has been great!

It’s the only way to make it work, tried many setups… that worked for me. Glad you sorted out :slight_smile:

Hey folks… just want to say thanks. The information here helped me get back up and running after a Hard Drive Crash forced me to jump from Cubase 6 to 10.5. Me and my Trusty US-2400 are up and running again. :smiley:

Hi martin, have you configuration for reason 11 suite?