setup headphones in Cubase 11 so they don’t crackle

Hi, I’m new to digital music creation and I’m extremely lost. No matter what I do, my headphones won’t work properly. Either there’s no sound or there’s sound that crackles occasionally and gets really bad after a brief period. Can someone help me remove the crackling altogether?
I’m working on the Asus ROG Flow X13 laptop with Razer BlackShark V2 headphones if that helps. I have 3 audio drivers: the built-in driver, the Realtek Audio driver that came with the device and doesn’t work at all with Cubase, and ASIO4All which I installed. I’ve been getting the best results with ASIO4All, but no matter what I change the buffer size to, crackling remains. I’ve also fidgeted around with the other values in the offline settings and I found sound DRASTICALLY improves when I toggle “always resample 44.1kHz <-> 44.8kHz”.
Can one of you awesome people help me figure this out? Since I’m new to this, extremely dumbed-down instructions would be much appreciated.
Thank you!!

Have you set the power scheme to ultimate or turned the steinberg one on? There are lots of audio tweaks that can be done on a pc. Also you can get latency mon program to see what may be causing the problem. The other thing I recommend is getting an audio interface that has its own asio driver and not use the internal audio of the pc with asio4all

Have a look at my post on PC performance (link below). Also, your most predictable results will be using an external A/D from your laptop sound card. You can pickup a cheap Focusrite, which includes their ASIO drivers. I would strongly recommend against ever using ASIO4ALL.