severe bugs in SpectraLayers 6.0.10


found no address to file bugs to, tried to report these via mail, but got no response.
find it a little disappointing - and cumbersome to go this route, hoping to end up with a product i can finally use.

the bugs really are “severe”, because they corrupt the audio files after saving them!!

Saving files in SpectraLayers mostly dumps all markers saved to the file previously with audition.
(I think this happens mainly to files from ZOOM H4n, not to other recorders I tried)

saving very long files (longer than 3h:??min, at least at 96 kHz 24-bit (so probably it depends on file size, not file length)) ends up with a file of the very same size as before, but it can’t be opened correctly with other programs, only the first part can be read, the rearward rest is unreadable.

Audition gives me this warning:
“none-audio data exceeds 100 MB and will not be read.”
“Metadata was found in the file but it was corrupted and could not be read.”

hope anybody will fix it, cheers, daniel

Hi Daniel,

1/ What format are you using ? Only the WAV format can store markers. There might also be different kind of markers in Audition. WAV markers read by SL are saved back if you export to WAV - but lost if you export to any other format. Would you have a sample file and step by step to reproduce the problem you see ?

2/ So you can open up them fine in SL, but it’s once you save them that they become unreadable ? Is SL capable of reading them back then ?
Problem is that long WAV files (>2GB) are not very standard, the WAV format was not originally designed to handle such lengths. I’ll look into that based on your feedback.
Meanwhile as a workaround you can save them to another lossless format such as FLAC.


hi robin,

  • all and only wav.
  • the kind of marker doesn´t matter.
    as i said, this only happens to the zoom-files, so i think it has sth. to do with how the recorder structures the metadata tags initially rather than audition. (i append short samples)
    (update: at least once as i tried to exceed the size-limit of 4 GB, SL also didnt read nor write back markers to a sony-pcm-d100-file)

SL also cant read back completely, thus i said it breaks the files.
and you´re partly right indeed, the problem occurs with everything above 4 GB!
but other programs have no trouble with larger sizes - so please let SL give a warning message at least before saving those until it’s fixed.

thanks a lot, daniel
3 H4n STE-004 with markers after (892 KB)
2 H4n STE-004 with (894 KB)
1 H4n (894 KB)

Hi Daniel,

I confirm the 2 bugs you reported are now fixed on my side, it will be in the second patch coming soon.

yeah, amazing:))) thanx!!

And, apart from the bug where you have to reset the ActiveX/OpenGL settings in the stand-alone SL app to get the Cubase3 10 window to work, there’s also the problem where if you apply the extension to one too many tracks, the timing goes out of sync for that track.

Having paid for this on a tight budget, it’d be great if it actually worked reliably.

Can you provide a detailed step by step to repro this issue, as well as a video if possible ? Can’t repro here. Thanks.