SHFT-ALT--> not extending note in 4.0.30

I am using Dorico 4.0.30in write mode and have grid duration of a whole note (the length of a bar). When I select a note and hit SHFT-ALT-arrow, the note selected does not extend, but moves (as for ALT-arrow).

EDIT: If I change the grid duration, there is no improvement.

Working fine here on a Mac with Monterey.


I use a PC with Windows 10.


For me it works as usual on Windows 10.

Thanks for your responses.

I have closed and reopened Dorico and am still getting the problem. It is the same with other note and grid duration values: if I select a note and hit SHFT-ALT-arrow (L/R): the note moves left or right by the grid duration.

Is it possible that I have un-set a variable by mistake somehow?


Yes, it’s certainly possible. Try quitting Dorico, then using Windows Explorer go to %APPDATA%\Steinberg\Dorico 4. You should see in there a file called keycommands_en.json. Move this aside temporarily, to another folder (e.g. onto your desktop). Now restart Dorico. Does the Shift+Alt+right arrow shortcut now work as expected?


I dont know where %APPDATA% is; but assuming this is what you mean: C:\Users\DAP\AppData\Roaming\Steinberg\Dorico-4, I found a file with the name you specified. I moved it and reopened Dorico.

No change.


Have you changed your keyboard language setting or made any other configuration changes to your system?


I have not changed keyboard language setting (I use a German layout keyboard) since I built the computer a year ago; but other things may have been changed – you cant avoid it with Windows and its updates! This is probably not a feature of the latest Dorico version, however, as I do not use this command very often – only when I encounter long held notes.

Can I put the .json file back now?


Yes, you can. You’ll need to restart Dorico again for it to pick it up once more. Take a look in the Key Commands page of Preferences for what you have defined for Note Editing > Lengthen Duration and Shorten Duration.

Problem solved: I was actually hitting Ctrl-Alt–> thinking it was Shft-Alt–>

Sorry for wasting your time. Thanks for help!