Showing rests in all voices in contrapuntal music

I am transcribing a 3-voice fugue for piano, in a 2-stave piano score. I would like all rests for each voice to be shown. For example, if voices are silent for entire bars, I would still like the rests shown explicitly for each voice in each bar, as well as for rests in parts of bars. This is common in many published editions of Bach fugues.

I can’t locate a prior direct answer in the user group.

I create a new project, with a solo piano template, then use “create voice” to add an additional voice in the right hand (2 in rh, 1 in lh). However, as I enter the first voice horizontally in the rh, note beams vary directions as if this were a solo voice. And no extra rests are inserted for the missing voices. Rests and correct stem directions appear only for bars once I’ve entered the 2nd voice in the rh.

I’ve followed the manual, and in Notations Options, have set in “Bar Voices in Additional Voices” to “Show Bar Rests”. The little example in the selection window is exactly what I’d like. However, even after activating, it doesn’t effect this behavior.

I must be missing something basic here. I’d just like to start with a clean empty score with visible rests for all 3 voices (2 in rh, 1 in lh), and have stems in the proper direction for each voice.

Any input appreciated.

small correction:

I set “Bar Rests in Additional Voices” (in Notations Options), not “Bar Voices”.

I can’t remember if this works but:

  • activate the caret
  • select which voice or create a new voice where necessary
  • Shift-B
  • type “rest” into the popover
1 Like

Thanks Daniel, but it doesn’t implement the desired format.

Have you got any material in the extra voices yet? I think you need to have music in there before you follow the steps I posted

The other thing you can try, if I’m not mistaken, is selecting the very first note of an extra voice, opening Properties, and deselecting “Starts Voice”.

Actually, it does seem to work – if the hidden voice is selected, not the entered voice. (I haven’t fully tested it though.) Not yet sure if it applies for all future measures, and certainly some later empty bars don’t have all the rests.

Just got your followup – thanks. It worked for the first few measures without music in the hidden voice, but not for some later bars.

There’s got to be a more systematic way, I’d think! (but this is a great start)

Perhaps this is where to check the status of the “starts voice”/“ends voice” properties. Good luck!

Still a bit confusing to follow.
Can you elaborate on the start/end voice approach?

And … I’d really like to set systematically for a flow, or project-wide, so I was looking into Notations Options. I thought Properties were ad hoc for a given scenario, not a global setting. And, still doesn’t explain why the “Notations Option” setting I did does not seem to be active.

Maybe you can post an example (Dorico file) here, with what you have managed so far. So we can give precise direction of what to do.

Basically, if you select the very last note and select Ends voice in the lower panel, it will remove all rests after. This is opposite for the very first note and selectingStarts voice. It might explain why some rests are there and others not… I don’t know.

I also think if you can post the project that we could give you a firm explanation.

Hi Daniel, Christian,
I’ll post followup on this later tomorrow – thanks

1 Like

Another possible solution is: (step 1) Select-All, (step 2) Filter by Notes and Chords, then (step 3) go to the property panel and deselect „start voice“ and „end voice“.
If you don’t see these properties you have to keep filtering after step 2: Change Filter to „deselect“, then deselect tuplets. After this follow step 3.

This isn’t a possible solution. Even with this Notation Option set:

…bar rests only show in additional voices after the voice has explicitly started (typically with a note).

See how the green voice doesn’t get a rest in bar 1, the purple voice doesn’t get rests in bars 1 or 2 etc.
The Notation Option only prevents bar rests from being hidden between notes within a voice, e.g. the purple rest in bar 6:

The only solution is to insert explicit rests in each voice, via Shift-B V (to the correct voice) rest Enter or via the Insert Bar Rest button in the Bars and Barlines section of the right panel.


I appreciate all the input.
On pianoleo’s post:
This is a nice example, and I’d add that not only are there no rests before a given voice starts, but also no rests after the current last bar with a note for a voice (e.g. bar 8 has no rests for purple, and bars 5 ff. have no rests for green).

I’ve tried selecting all future bars, and select an appropriate voice (V toggle with caret active), and then try to insert explicit rests, as you suggest – via Shift-B V “rest” (enter). Only the first bar in the selected section gets the appropriate rest in that voice.

Any further input? Basically, it would be nice to enter a multi-voice fugue, for ex., one voice at a time, where the stem directions are all correct and finalized for that voice as it is being entered, and with appropriate rests for the other voices.

On the input from other posters:
I’m having trouble understanding the role of start/end voice, and why I would need to work with the Properties panel for changes that ideally are default for a given Flow or Project. Also, not clear if an example project needs to be posted, pianoleo’s is quite relevant, I’m really asking about general principles.

I’m relatively new to Dorico, so step-by-step input appreciated.

I am pretty amazed at the capabilities and optimized defaults of Dorico, so I’m a bit surprised this contrapuntal scoring, with individual voice entry with appropriate stems and pre-allocated rests, seems so complex.

A followup:

Given pianoleo’s comment and example, that the multi-voice rests are shown only in bars between those with inputted notes, I simply went to the last bar of the flow and entered rests for each voice in that one bar. (So the last bar has ‘something’ in each voice.) Then all the preceding bars got the appropriate multi-voice rests!