Shuttle Pro Nightmare with Cubase Elements

Hello, I’m a new Cubase user and like it a lot so far BUT have been pulling my hair out for several hours. Steinberg has not been great help so far. Here is my issue:

I am using Cubase Elements 9.5. I’ve purchased a Contour Shuttle Pro V2 to use as a controller. Cubase, no matter what I try (after hours of trying) does not recognize key command changes. I have tried the Shuttle Pro in various programs including, Word, Notepad, Reaper, Cakewalk, Internet Explorer and Excel. Every program responds exactly as it should in relation to the commands I program into Shuttle Pro. Cubase will ONLY use the commands that are pre-set and will not change them. So, for example, the upper left key of the shuttle pro is set to send “F8”. I reprogram it to send “Space”. Shuttle Pro confirms the change. But Cubase still only sees “F8”.

The Shuttle is, for all intents and purposes, a type of keyboard. I can’t see any reason why only Cubase refuses to accept simple key command from it. EVERY other program I’ve tried (DAW or other) works perfectly.

Oh, and to be clear: The “pre-assigned” keys on Shuttle Pro work fine with Cubase. So, Cubase is SEEING the Shuttle, just not letting me change key commands.

Sorry for the long description. Any ideas?

Since it’s just a keyboard as far as Cubase is concerned, it’s impossible for Cubase to receive anything aside from what its sending.

Cubase has nothing to do with any aspect of configuring the Shuttle Pro, and only passively receives whatever the device is sending. One thought is, If you are able to configure it differently for different programs, you probably are not changing the config for Cubase.

Hi Steve, thanks for the reply. I agree with you completely that, as far as Cubase is concerned, it’s just a keyboard. This is why I’m baffled. Cubase is, indeed, receiving something other than what the Shuttle is sending as I’ve confirmed it by looking in Key Commands window where it allows you to see what key is being sent (from keyboard or controller). Also, I’ve confirmed that the Shuttle is sending the correct commands by testing it in many other programs (as I indicated in my post).

Regarding config: There are two options, neither of which works. Global settings, which affects all applications the same and a Cubase setting (user defined). So, in other words, no config should be necessary as Cubase is a passive receiver as you indicated. Put another way…NO config works.

I am truly mystified.

How do you select the Cubase Elements executable from the Shuttle interface?

How do you verify that you have selected the right executable?

Not sure what you mean when you ask how to verify the correct exe. I select the Cubase Elements 9.5 executable. I manually double click on that exe to verify that it is, indeed, my program. Also, as I indicated, it doesn’t matter if you are in global mode. Shuttle Pro will affect ALL apps the same…including Cubase. In other words, no Cubase config should be necessary whatsoever. It is simply responding to an external keyboard.

I spoke to Jeff at Steinberg 20 minutes ago and he is just as stumped as I am. He confirmed that Cubase should be receiving the key commands from Shuttle Pro as sent and also agreed that it sounds like a Cubase issue and not a Shuttle Pro issue. He is sending a message to Germany for more info.

To be clear, I have been at this, literally, over ten hours over yesterday and today. I have tried every conceivable config and still no joy. Last thing I tried was to make sure permissions on all relevant directories we set to “All”. Still nothing.

That is very strange. Are you saying that even if you change the keystroke a button sends in the global set, Cubase still displays the old keystroke in the key commands dialog “Type in key” field?

Is this helpful: https://www.contourdesign.com/support/product-support/#1493827530165-dabc408d-97ba ? (are you on Win or Mac?)

Exactly. My Shuttle is set to send a “Space” key command and Cubase responds by indicating I am hitting the F8 key (in this particular key instance). No matter what I change that particular key to, using Global Settings (or any setting for that matter), Cubase only will say I’m hitting “F8”. I’m completely baffled. The only other thing I can think of is that it somehow has something to do with my Windows 10 configuration. But that still makes no sense as all other programs work exactly as they should using the Shuttle.

I swear, I’m gonna get to the bottom of this! :exclamation: :cry:

AHHHHH!! That did it! That was the one thing I hadn’t tried!

Steve, THANK YOU! You saved my sanity!

I owe you !

Excellent!

Im having a similar issue. I have a Shuttle Pro V2, and am using Cubase Pro 10.5. The driver is updated, and the Shuttle Pro is showing up in the system tray. It works with other applications, but will Cubase Pro 10.5 will NOT respond to it.

Any help would be greatly appreciated.