sick & tired of elicenser

Have been having trouble with older eLicenser USB stick. It was recommended I buy a new, chubby one. I did. Managed to successfully activate it. Now, when I try to activate my Steinberg apps it tells me my activation codes have already been used. I already spent a few hours trying to find how to get access to Cubase, Dorico etc. Where do I get activation codes? As much as I like Steinberg software but elicenser sucks!

iMac MacOS 10.13

Hi,

Don’t activate the licenses again. Plug both USB-eLicenser in and drag and drop the licenses in the eLCC application to the new one. If you can’t do it on your Mac (because you have a problem work your old USB-eLicenser there), you can do it at any computer. Just eLCC application has to be installed on the computer.

What about the fact that the eLicenser software has to be running on in order for the plugins on that eLicenser to work and not get errors/crashes when loading projects in any DAW. I spoke to a few of the plugin manufacturers and they are blaming it on Steinberg and this is a known issue. I guess they won’t be fixing this, it’s ok I don’t need anything from Steinberg, iLok is way better.

Please post or pm the replies you mention. Obviously, whether it’s ilok, elc, or any software that that runs on a computer, it has to be running to be running.

Hi,

I would strongly recommend to update to the latest eLCC 6.12. There are important fixes in it (especially for Mac).

Confirmed, this fixes a number of errors on Catalina (makes no difference on Win10 1909, that always worked).

Until now, I’d thought this was the fault of the DAW vendors in not recognising Synopsos /security settings. But no, now that the update is installed, all works as it should. eg: 1) Logic had problems in loading Steinberg VIs, the temporary fix was to open the eLicenser first & run in the background. 2) UA’s new DAW ‘Luna’ would not run any Steinberg plugs (no Synopsos showing for Luna in Security prefs at all); now opens all plugs as it should.

Hi Martin,

Yesterday I bought UR22C. I am having problem with eLc version 6.12.1.1267 (Win64) while activating Access code for Cubase AI. The UI shows the activation code with 40 Characters but the given access code is with 25 characters. When I press continue it says the elc is too old, I should update the software whereas 6.12.1.1267 is the latest. I didn’t face problem with Basic Fx Suite though. I have tried several times by uninstalling and installing again but the problem prevails. Would you please help me how I can solve the problem?

Kind regards,
Chitta

Hi,

Activation Code is not Download Access Code. Please follow the instructions… Use Download Access Code in your MySteinberg account to get an Activation Code.

Don’t get me started with the eLicenser. I asked support about why cubase was randomly crashing and why it doesn’t always close properly. I was adviced to use my internal graphics which is fine but…eLicenser wouldn’t work after I updated the internal gpu because I had made changes to my system. It took me ages to get it back running and If they would have told me that was going to happen I would never had tried it. People don’t see a issue but too many companies don’t use a dongle and still have major success.