silence generator screenposition

Not sure if it’s really a bug, but I have a strange/annoying issue with the screen position of the silence generator.
I need to use it to get rid of dropouts in the first second with the use of analog gear (external gear plugin) and '‘record what is played back’. I always add 1 second of silence before a wav file and cut that off afterwards. Still the only option to hear the audio processing…
OK, the issue…
When I open it and close the silence generator and open again it is shifted a bit more to the top of my screen. Next time I open it a bit more and more etc. Untill it’s on the edge of my screen and I can’t acces the X and have to close it with escape. No other windows do that as far as I can see, just the silence generator with a shortcut from my CMC ai controller.
I think (almost sure) I did not have that problem with wl8 and before.

Does the shifting still happen if you once moved it yourself with the mouse? I have a similar issue where first the position of recording and analyzing windows are not remembered between WL sessions, but if I open and close without moving the position shifts every time - I’ll have to check whether this is still so in the current version since I always move it manually the first time.

Tried that, but it doesn’t work. I know what you mean, it happened to me with the recording window as well, now it doesn’t.

PG? Can you confirm this?

I can’t confirm that.
Are you really using 9.0.25? There was a related bug before that version.
Also, where do you put the dialog on screen? (special place?)

Yes, running 9.0.25 in win10x64.
It’s on my main screen, the second screen I use is for plugins and meters.
I dont see that behaviour with other screens like recording or saving files (I have set it to open quick file selector when saving files)'so I guess it’s just the silence generator screen.

Any news on this PG? It starts to annoy me to be honest…

I could not reproduce this problem.
Maybe some screen shot could give me an hint.

I’m afraid a screenshot will not add anything since you can only see that the screen popsup a bit shifted everytime untill it’s at the edge and you can’t click the x but have to press the esc key to close the window.
I think it’s just the silence generator.

I’m afraid a screenshot will not add anything

I would not say so. Especially if you give 2 screen shots (2 different positions of the dialog).

They are shifted apart each time, starting at the bottom, then everytime you open it it shifts to the left, then a bit up and to the left again. just like as if you get error popups that get on top of eachother and clicking it would open a new one shifted on top. Except this is not an errorscreen and not on top of eachother, but the insert silence screen. Every time you open it and close it, it’s shifted. Can’t make it more clear i’m afraid, but it’s 100% reproducable on win10x64

I changed some things in screen postiioning (swapped screens) and that also didn’t change a thing. The silence generator is still moving everytime you open and close it. 100% reproducable.

PG, have you looked into this already?
I made a small movie about the problem, opening and closing the silence generator a couple of times.
You can see the moving/shifting of the window.
It just happens with the silence generator, not with other windows.

I could never reproduce what you show. Can you recall me your screen configuration?

It’s a basic 2 screen config, one screen holding the main window and the second the metering and plugins.
Quite recently I changed to a 3 screen config with 1 screen for metering, one for main/edit window and one with pluginns. I had to replace the videocard to get that working btw, so if it was the videocard it should have been gone now.
Changing the main window to different screens and things didn’t matter at all and also changing the default settings did nothing.
All of those things didn’t matter and have exactly the same behaviour, also going to 9.035 and things like that didn’t change it.
It’s 100% reproducable and just the silence generator as far as I can see.
I do have a shortcut on a cmc ai controller (f3) to open the silence generator if that might help.
Running win10x64, videocard AMD Radeon R7 250 serries with latest drivers. 2 screens 1920x1080 and 1 screen 1600x900 (that one is main screen right now)

I also have 3 screens, but not this problem.
I note to look in the code again, but this is not on top of my todo list.