Simulanalog Guitar suite.

Does anyone remember the free Simulanalog Guitar suite?

I found it amongst my old plugins, installed it, tried the Marshall JCM900 emulation and was shocked at how good it sounded with just the default setting.

I have several other amp sims including NI Guitar Rig, both Kuassa sims as well as a Waves one but would be pushing it to find a really good basic sound just like that, amazing.

As the Suite is rather old, and therefore 32bit, I’m using jBridge to successfully run them, I don’t know if they work with Cubase’s VSTbridge.

In case some of you are interested here’s a couple of links.

Original basic UI with sliders: http://www.simulanalog.org/guitarsuite.htm

With realistic looking nice UI: http://requietus.blogspot.com.au/2008/12/simulanalog-guitar-suite-gui.html

Yep, remember these, stunning for that time. The developer was T. Serafini, who later developed Overloud’s amp simulators. If I’m not mistaken, the improved Simulanalog models ended up in TH1 (and later incarnations, now at version 3).

Yes, I’ve used this free VST a lot.
The Tube Screamer is great for giving clean sounds a little edge.

Thanks Mauri, will check it out. On another note, I got a little cash for Xmas, thinking of spending it on Scuffham S-Gear, which really sounds tremendous.

Cheers.

Hi Mauri

(Pleased to meet you, Fabio, and best wishes, Wim and Robin)

This Guitar suite, recommended to me by Kim (Grusom) was one of my main guitar plugins. It WAS my guitar sound throughout my early cubsase audio days.

Until I found:
http://nomadfactory.com/products/ral/index.html

I mention this for historical purposes only. I am still totally in awe of what Simulanalog created. In my mind’s ear I can still hear what it did to my guitar sound. An early and beautiful relationship between touch sensitivity on string and sensitivity of tone. It gave balls to my musical life.

Meanwhile, Mauri and all, I wish you a very happy new year, and best wishes and respect to all on this forum.

Take care

Glyn.

@Glyn,

Nice to see you pop in here, all the best to you and yours too :slight_smile: !

PROBLEM!

I use Cubase 8.5 and Jbridge for this plugin. But when I click on the “e” icon to show it’s panels, I only see a white image in the window and can’t do anything. Anyone got the same error and know a solution?