Since v12.0.20 my arturia minilab MK II no longer works in CB Pro 12

As the title says yet another issue with Cubase Pro 12.

Since installing the v12.0.20 update my arturia minilab MK II no longer works in CB Pro 12.

The arturia minilab MK II is one of the keyboard/controllers that Steinberg provided a script for and BEFORE installing v12.0.20 update mine worked as it should so something was changed in the new update.

Since this happened I have updated the keyboards firmware, and untinstalled the Arturia Software Center and MIDI Control Center, and installed the latest version but it made no difference.

Now if I open a new project and add one instrument track (it does not matter what instrument I choose), and play the keyboard I can see midi activity in the bottom right hand corner but nothing is being passed to the instrument and if I hit record, nothing is being recorded.

If I close CB 12 and open CB 11, the keyboard works perfectly, and the same in Pro Tools and Ableton so it IS a CB 12 issue.

When will these endless problems stop?

Hi,

Make sure, the MIDI Input is not in use for any Remote Device, please.

Hi Martin and thank you for your reply.

Can I ask what you mean by MIDI Input>

On the instrument track (in my blank test project) the MIDUI input is the Cubase default (All MIDI Inputs) and in Studio Setup > MIDI Port Setup > WinRT MIDI > In All MIDI Inputs is ticked.

Hi,

I mean the MIDI Input of the Remote Device(s) in the Studio Setup.

Thank you for coming back on this.

I have not changed any settings, they are exactly as they were before I installed the v12.0.20 update.

In Studio Setup > MIDI Remote > the script for the MiniLab is showing with Input = Arturia MiniLab mkII.

If I open the lower MIDI Remote window the MiniLab is showing buy everything is greyed out.

If I then click on the left hand cog and open the MIDI Remote Manager it says that the MiniLab is “disconnected” but cubase shows that there is MIDI activity.

Hi,

I’m sorry, I’m really not asking for the MIDI Remote, I’m asking for the Remote Devices.

Hi Martin
I can confrm that nothing is selected for MIDI Input.

Hi,

What about the Mackie Control, Track Quick Controls and VST Quick Controls? Do they use the miniLab MIDI Input by any chance?

The Mackie Controls are setup for my SSL UF8 which is not connected at this time.

Track quick controls are not assigned to anything MIDI Input & Output = Not Connected.

Before update v12.0.20, I had my UF8, Korg nanoKontrol Studio and Arturia MiniLap all connected and fully working at the same time.

Hi,

Is the minilab switched to the expected mode, please?

As far as I know it is in Cubase mode, Shift + Pad 2

and I have tried Shift + Pad 1

It is very strange, Cubase 12 shows that it is receiving midi in the bottom right Activity indicator but cubase is not passing that to the instrument track.

Also if I open Arturia Analog Lab none of the controls are connected to the rotary pots on the MiniLab

Hi,

Could you try to reinstall Cubase (as administrator), please?

From Version 12.0.00 then V12.0.10 then v12.0.20?

Would that also mean having to reinstall all of my plugins?

Just checked in Download Assistant and I can not see a was of installing as Admin.

I know how to do it if I was installing it with DL Assistant

I can confirm that I have uninstalled Cubase Pro 12 completely, then re-installed v12.0…00, v12.0.10 and then v12.0…20 all as admin.

It has made no difference.

Hi,

I was thinking just download the 12.0.20 update and don’t install it from the Download Assistant, but install it manually (as administrator) from the installer.

Hi Martin

Thats a good idea and it is what I did but sadly it makes no difference.

Hi,

Could you try to roll back to Cubase 12.0.10 just to test if it’s working was expected there, please?

Could you try to start Cubase in the Safe Start Mode [Disable preferences]? Does it work then?