Ski Remote and iC Pro

I have the latest versions of iC Pro on my iPhone 6sPlus And the latest version of the SKI Remote as well as Bonjour on my Windows 10 system. I went down the checklist of troubleshooting suggestions and all checked out. Bonjour is running. If I check under the SKI Remote dialogue box it show my computer and the IP address that is assigned by my Wireless router. I am attaching a screenshot.
When I launch the app from my iPhone, it recognizes the computer and when I try to connect it just spins and spins and spin and this is sitting 5 feet away from my router. If I try to launch it on my ASUS Android Tablet (yes I know they are two different apps and I have paid for both), the computer name comes up and if I click on it I get a message "There is no host assigned to this IP address. Make sure your eLicenser is activated. I did a fresh synchronization of my dongle and still the same problem.
I had this working well with my Android tablet until 6 months ago when Comcast changed their routers and a new IP protocol that is not the standard 192.168.1.***. I dumped them this week and had FIOS fiber optic service installed that uses the standard protocol. I have many singer/songwriter clients and I end up playing a lot of instruments on their recordings and I need to be able to control Cubase from the cutting room.
Any help is greatly appreciated. Thanks in advance
PS I have tried this on my versions of C8.5 and C9 Pro. In C9 it came up briefly on my iPhone when I opened Cubase, but once I loaded a project the app booted back to the initial screen and just spins when I select the computer

Is no one using this App on their iPad or iPhone?

I’m having the same exact problem. I use an iPhone 6sPlus, as well, and before the whole iOS update issue that caused Cubase IC Pro to go haywire, it had run perfectly with Cubase 8.5 and this phone.