SLP 7 suddenly hangs

I am in the middle of cleaning up a piano recording (pedal noise, ect) The file is a 44.1kHz/24 bit PCM and about 35 minutes in length.
Everything was normal for an hour or so) but after a 30 minute break, SLP’s click and drag tools (specifically erase, amplify) stopped responding normally. Dragging the erase cursor does not move until after about 10 seconds, then it suddenly jumps, then SLP totally locks up for another 10 seconds or so. The other functions and menu items seem to work normally. I tried other PCM files and it is basically same behavior but the delay/hang seems longer on the larger sized files.
Other applications like Sound Forge and Vegas operate normally. which leads me to believe it is not a PC issue. The same behavior happens in a stand alone or as an ARA plug-in with Sound Forge. The same as well as a SLP project file or with a file opened directly.
I reset SLP’s preferences but that did not help. Can anyone think of a setting or shortcut key that may have inadvertently changed something? I have tried all the usually procedures (cold boot, ect) and cannot think of anything else aside from reinstalling. Is there a full SLP reset and/or a cache clear option? Thanks for any help.

Thanks, Poinzy
SLP worked fine just prior and heat is not the problem, nor was there a Win 10 update when I took a break,
FWIW, I am using a Win-10, Dell XPS 15-9550 laptop with a quad core i7 CPU; 32 GB RAM; solid state HD (with ample free space); NVIDIA GTX 960M graphics card. As I stated, other applications performance including SFP and VP are unaffected.

A test you can do:
-Make sure the Resolution setting (in the Display Panel) is set to no higher x2
-Make sure the FFT Size setting (in the Display Panel) is set to no higher than 4096
-Make sure to only have one or two layers visible max
-Make sure to only drag the eraser tool over 10 seconds of audio max at once in one stroke
Given those 4 conditions, let me know if you still experience the kind of freezes you’ve been having.

Thanks Robin,
I was working in the 40 to 200Hz frequency region with the resolution setting maxed out (or close to it) and a high FET setting as well. The problem also may have been exasperated because I was using two monitors displaying the same image (not extended) my laptop’s display and a large secondary monitor displaying the same screen… I also did a huge number of erase procedures, without updating the (500+MB) file. In any case SLP seems OK now.
Thanks again for your guidance Robin, I appreciated it.
btw, I was able to eliminate the grand piano’s pedal noise satisfactorily, though it took some time, which I have a lot of these days and I was not working on an hourly pay scale,

1 Like

btw, is there preset utility for the “Display” parameters?. I can Save and Load custom Interface Layouts, but the ‘Display’ parameters always revert to the default settings .

Some parameters like the freq/time range, FFT Size and others are saved and loaded with your project.
But you can also customize the default settings by going to Edit > Preferences > Display.
There will likely be a focus on presets in the next version of SpectraLayers.

Thanks again Robin.
Having custom display presets for different types of repair scenarios would be nice. For now, I will save as a SLP project more often.

1 Like