Sluggish Playback in Dorico 4

Hi! Just purchased Dorico 4 and so far I’m enjoying it…but…

When I hit ‘Play’ from the Transport it stalls for 1-2 seconds before actually playing back. This is on a very simple 5 bar, solo piano project. Actually, regardless of the situation, playback consistently lags by 1-2 seconds after hitting the ‘Play’ button. Not using any special plug-ins, just stock Dorico piano sound.

Is this normal for Dorico?

Thanks for any help in advance.

Also I should add I’m on a Macbook Air M1. Tried opening Dorico using Rosetta but that didn’t help.

Welcome to the forum, ryanl !
Such a lag is not “normal” with Dorico, especially if you’re not using NotePerformer (which takes a 1s delay before play to calculate its phrasing). You should probably go to help menu, create diagnostic files and post them here so that someone from the team can help you further.

Hi Marc, thanks for the response!

I’ve attached the Diagnostics zip file for the team!

Dorico (564.5 KB)

1 Like

I’ve had a look through the log file and there’s nothing very unusual in there. You have a low buffer size which should help keep things responsive. However, I’ve compared the log to doing the same thing on my own machine and I get slightly different results. It looks like the play button is being pressed twice, so effectively it’s starting, stopping and then starting again. Do you have a very sensitive mouse, or are you double-clicking it? If you press space to play then is that fast?

1 Like

Hi Paul!

I’m using just the built-in trackpad and keyboard on the M1 Macbook Air. The 1-2s delay occurs whether I use the space-bar or manually click the Play button in the transport.

After hitting Play, the green playback marker appears on the staff instantly but then doesn’t start actually playing until after the delay.

Any other ideas for troubleshooting?

I’m sorry, I can’t really think of anything else, as there’s nothing really unusual in the logs. Try disconnecting any MIDI devices. Maybe @Ulf might have some ideas for things I’ve missed.

Could you be dealing with a midi feedback loop to a connected keyboard? What does the little green dot show down in the right corner? What other programs are you running in the background?

Other than the from Paul mentioned repeated Start/Stop commands I also don’t see anything unusual in the logs, so I would investigate in line with what Romanos said. Those repeated start/stops must come from somewhere…

@Romanos No midi devices are connected. No little green dot is displaying in the right corner. I’ve exited all other programs but the problem persists.

@Ulf is it worth trying to re-install everything? Would I do that manually or through the Steinberg Download Assistant?

Have you checked the Pre-roll setting in the ‘Timing’ tab in Playback Options?

@Grainger2001 thanks for the suggestion. The Pre-Roll is already set to 0s. I also turned off the count-in for the click under Playback Options but that hasn’t helped. Hmm…

Hi @ryanl ,
I don’t see how a reinstallation should improve that behaviour.
However, you could do a little bit of research yourself.
E.g., the diagnostics report always contains the current Dorico log. You can extract the diagnostics report and then in the Dorico subfolder look for application.log. The log file can be opened with a text editor and with Ctrl-F you can search in there for ITransport::start. So normally, if you click the Play button that line shall only appears once. Then it is time to play around a bit. Compare what happens if you click with the mouse on the Play button or if you hit briefly the space bar. Do both actions produce the same output in the application .log?
Make longer or shorter clicks/key presses, does something change in the log?

1 Like

Hi @Ulf I did some more digging around and the ITransport::start and stop appear to be behaving normally in the application.log file. In the file I uploaded you can see I let things play for longer to show a wider gap in the log file.

I’ve also looked up some videos on YouTube and it seems like playback on others’ systems also has a slight delay. I’m beginning to think this is normal, this slight delay. I’m used to MuseScore where Playback is literally instantaneous to when I hit Play.

Is playback instantaneous for everyone else here except me? I’m beginning to think I’m going mad lol.
Dorico (544.8 KB)

You are right that there’s a slight delay in Dorico that you don’t have in MuseScore. But honestly I got used to it — I even got used to the 1s delay from NotePerformer. I’m beginning to think there’s no problem on your system :person_shrugging:

@MarcLarcher gotcha, makes sense. ok, no big deal really. I’m enjoying Dorico otherwise so i’m sure I’ll get used to it.

Thanks again everyone for the help!!

Also found this thread with someone having the same issue.

@Ulf @PaulWalmsley Is this playback delay something that could potentially be minimized or completely resolved in future updates? It is somewhat of a hamper on an otherwise awesome piece of software. Thanks.

The delay can perhaps be further reduced, but it can probably not be completely eliminated. Depending on what you did immediately before you started playback, Dorico may have to recalculate some or all of the playback data for the project. There is not a one-to-one mapping between items you see in the score and MIDI data for playback – to take an obvious case, a trill or tremolo may need to generate multiple notes (and it has to determine what those notes should be, how many of them there should be, how fast they should be, etc. etc.). Similarly, to produce detailed playback using key switches, MIDI continuous controllers etc. following the settings of the current playback template is non-trivial. So unless you have not edited the score since you last played back, there will always be some amount of processing required.

I’ve had a look at your preferences file and I notice one difference between yours and mine: Preferences > Play > Show playhead when stopped. Try turning that on and see if that fixes it.