Slurs over system breaks (again)

I’ve just hit a horrible quintet of slurs at a system break. I know this has been raised before – eg here – but I don’t think these are the edge cases that Daniel refers to. Sure, I can manually move the bar line in Engrave mode, giving the slurs more room, but I’m finding this a lot in this current piece.

And here’s the galley view of the same bar plus the following:

I don’t want to unilaterally increase the space before a bar line so I’d be grateful for any suggestions on easy workarounds. I’m finding problems too, when slurring to notes with accidentals across system breaks and various other problems that, again, I wouldn’t call edge cases.

Edit: Dorico, Mac OS Ventura 13.3.1, Mac Studio Ultra

1 Like

What are your settings for Engraving Options > Slurs > Slurs Over System Breaks?

Thanks, @benwiggy – I tried changing the horizontal gap (set to default of 1/2 space) but that didn’t help. I even tried negative values but that ruined other system breaks and I don’t like anything going outside the music frame. I don’t think the vertical gap is relevant but do correct me if I’m wrong.

What about the “Interpolation” setting? If it’s off, turn it on, and vice versa!

1 Like

Nah - doesn’t help. It changes the angle of the end point of the slur on staves 1, 2 and 5 but they are still wrong. Doesn’t help at all with the vertical slur on stave 4 or the “eyebrow” on system 3.

It’s obviously a tough one since we all first came across these ‘pinched’ slurs years ago. As always, the request is simple. When there are slurs at the end of a system, give more room before the final barline. Clearly, implementing the “simple request” is rather more difficult…

If you use this setting:

you get this:

… which is a bit better. Whether that spoils slurs somewhere else, you’ll have to see.

The real problem is the fourth staff down, which has a slur across ‘opposite’ stem directions. Dorico does have a setting (next one down) to deal with opposing stems, but it doesn’t seem to help here.

1 Like

Thanks for going the extra yard on this for me. Much appreciated.

I haven’t used that setting before but it it helps in this case. However, to get the same results as you, I also had to change the Note Spacing in Engrave Mode to give room before the bar line. I agree, though, that it’s much better.

Yes, cross system slurs to opposite stem directions (whether the stems exist or not) is another problem (which is made worse by flipping slur direction) - there’s a bunch of topics here that could do with a revision.

My score is a biggish one (21 staves) and so I’m working with rastral size 8 in A4, fwiw.

If you don’t mind, I won’t mark your suggestion as a solution, since I’d rather this topic remained open. You’ve been very helpful, though. Thanks again.

I used my defaults, so perhaps there is a setting somewhere that gives a bit more room…

1 Like