Snap on off in tempo track isnt snapping when using the write tool

Turned snap on.
Click anywhere on the tempo line - does not snap - writes wherever clicked. need to then drag the new point to get it to snap. Please advise!

Hm.

If you are using the Select Tool, when you pass over the Tempo track line, it changes into the Draw Tool. But it’s not as fabulous as the original Draw Tool. You see, if you perform a single click right then and there, it will not obey to snap. But if you instead move the mouse the tiniest amount to the left or right after you have pressed the mouse button down and before you have released it, the event will snap to grid.

On the other hand, the original Draw Tool (Default key 8) will always obey to snap, and allow to directly click on any value, even if it’s not on the line.
Tempo track snap

I don’t know if that’s the plan, but that’s how it works currently. Thanks for bringing this up, I too was wondering why the tempo track was misbehaving at times but never sat down to find out why. Now I know why!

Thanks for looking into this! Thats helpful!

having to delve so deep into something that should be intuitive out of the box makes me think its a bug. maybe keyboard modifiers - like snap to current temp and snap to current position? because sometimes one wants a ramp start tempo mark without messing up the whole project

Btw, another feature request would a button “Add tempo mark / keyframe at current cursor position” (am i missing something? most daw and NLEs have something like that for tempos and key frames.)

If there’s a bug, it’s that this “Auto-change-select-tool-into-draw-tool” does not snap to grid automatically. The ordinary draw tool does work as advertised.

The modifier to temporarily disable snap is Ctrl. To enable/disable snap at an time use J. There’s no key to specifically temporarily enable snap. It’s assumed that we work with snap on and just use Ctrl if we want to do something off the grid.