Snap to Zero Crossing Not Working?

Hi, Folks. I’m pretty new to Cubase. Migrating from Cakewalk. Anyway, I have ‘Snap to Zero Crossing’ enabled, but it seems to have no effect when I split audio parts in the arranger. Are there other settings that come into play with this feature? Is there a modifier I have to use in conjunction with it? Is it a known bug (my cursory search of the forum didn’t suggest so)? Thanks for any insight you can provide.


It works to me here. Could you attach a screenshot, where does it cut instead of 0, please?

Thanks for the response, Martin. It’s working now, but the day I was experiencing the issue, ‘Snap to Zero Crossing’ would only work when I used it in conjunction with ‘Snap’. I’m not sure what other variable might have been involved to account for the discrepancy, but at least it’s working as expected now.


I was thinking about a conflict with the Snap, so I tested both combinations (Snap On/Off) today. Btw, if you have a stereo signal and the signal doesn’t cross 0 at the same time for both channels, the Zero Crossing point could be shifted (close to the lowest value, summed of both channels).

Thanks, Martin. It was a mono audio part and would split wherever I clicked it, at any point in the waveform, even though ‘Snap to Zero Crossing’ was enabled.