soft-eLicenser lost my Elements 10.5 licence after Windows re-install

After an unfortunate issue, I had to re-install Windows. I had a copy of Elements 10.5 on an education license, but after the re-install, the soft-eLicenser seems to have forgotten its existence; my only eLicenser only shows “no products found…” (For clarity, this copy of Elements is my only product anyway) and under the Registration tab, it says “there is no valid Steinberg product license found…”. The copy of Elements was fully registered before the re-install, I just don’t understand how it could go “missing” like this.
I created a support ticket (#496765) nearly a month ago, but I have had no response, and it is still open.

For context, it is an education copy of Cubase Elements 10.5, provided in a small box with a download code (which I still have). There is no license included, just a download code, so I cannot enter the license number again. The re-install was done on a different HDD as before the re-install, but the original drive is still present and in use. Both were wiped before the re-install, but I kept select folders from the old install while I could still access it, which include any folder labelled “steinberg” or “cubase”. I could not copy the registry across. Windows 10 21H2 was used before and after the re-install.

Are you sure you’re logged in to the correct MySteinberg account? Log-in and try registering your download access code to it. What does it say?

Thanks for the reply! Just tried both of these. I’ve tried all my emails in the “Forgot Password” box, and none of them exist besides this one. It’s always been registered to this one, AFAIK.
I tried the download access code, and it said “Download Access Code is already consumed by another user. Please contact your local support team.” Which would make sense, since I already redeemed it years back.