Soft elicenser not working blank Elicenser window

Hi
I had been using Cubase for a few months without a problem
Today I tried to install Dorico but the soft elicenser did not work properly. I had to reinstall it.
Now i cannot activate both Cubase and Dorico. The interface of elicenser looks strange. There are empty buttons on it. Please see the pic below. I downloaded the latest version and reinstalled but it still looks the same and does not work. I ll be pleased if someone help.
Thanks

possibly related to: License Server Outages

Thanks very much for your help steve.
I have managed to activate Dorico SE. But steel having problem with Cubase Elements.
The activation code that was sent to me has 25 characters but elicenser activation window is asking for 32 characters so my activation code does not fit. Do you have any idea about the cause?
Ekran görüntüsü 2021-03-01 220444

Could that be a “Download Code” for the Steinberg Download Assistant?

Thanks very much again. You are right. What i was sent was the download access code.
I activated this product a few months ago and the old activation code didn’t work this time. I guess i need to reactivate.I followed the instructions on the website but the elicenser still does not work properly. Empty buttons,empty menus… I reinstalled the latest version several times but its the same. I could not complete the re-activation process. Do you have any suggestion?

That, I do not know. But I’ll move this to the Dorico category, to get some new eyes on your issue.

Thanks very much for your help

I’ve not seen this kind of issue before with eLicenser Control Center. I’ll have to ask my colleagues in Hamburg whether they have any ideas.

@ulasyetkili, I assume you’ve tried the obvious solutions like restarting your computer, applying any pending Windows Updates, etc.?

@dspreadbury , yes sure… Restarting did not change anything and windows is up to date. I am happy about the performance of the pc actually. My previous daw and all my instruments work perfectly fine. I also use ilok for some instruments and it works fine. Elicenser worked fine when i first installed Cubase in November . But now the gui looks strange and do not function. I wonder if it is clashing with any other software i have installed since November. I don’t won’t to format the pc because of this. I appreciate any help. Thanks in advance.

I’ll ask my colleagues in Hamburg whether they have any ideas and will come back to you as soon as I can.

My colleagues in Hamburg say that they have seen this problem when the language settings are set to Turkish or Azeri (Latin) in Windows. Please try setting your language settings to a different language (e.g. English) temporarily, then see whether you can run eLCC successfully.

Thanks very much!
Elicenser works fine now. All the anomalies went back to normal and i was able to reactivate.
I am grateful for your help.
Best wishes

1 Like

I’m glad to hear that solved things for you.