soft elicenser problem

i hve problem with activating my cubase le.
i want to active my cubase but in elcc there is no soft elicenser and i dont have any USB eLicenser i tryed elc-installation-helper but not worked .
please help me

Hi and welcome,

Follow these instructions.

Hi Martin

I have the same problem as Maxell.

When installing the eLC Installation Helper given in the instruction, a failure occurs:
“Installation failure. Installation failed.”
Windows 10 defines this utility as “Incompatible program”.
What do we do? How do I get Soft eLicenser so that I can successfully download and run cubase Al?


i have the same problem.


Hi and welcome,

Try to uninstall eLCC completely first. Make sure, your Windows system is up to date. Then try to install the eLCC helper again, please.


I have a similar problem like most of people here.
Bought an UR22mk2 last year with Cubase AI 10. I installed it and activated and everything was ok.
Then i upgraded my ssd and needed to reinstall the cubase and elicencer software, the problem was Cubase was saying i already activated it and was saying there is no valid licence and it wont start.
Ok, so i found a solution to reinstall eLicencer software, got a new serial for it, started the reactivation process, got an new activation number, i entered in , it succesfully validated. And then i start Cubase again saying no valid licence found and its shutting down???
Whats the catch in this stuff? Does anyone know?
I even reinstalled both cubase and eLicencer software again went the whole process 3 times as i thought i was doing something wrong bot every time i get the same error. I dont mind going to Ableton but really wanted to try Cubase.

Best of luck to everyone and hoping for a positive response.

Hi and welcome,

Make sure you have installed Cubase 10.0.60 (if your license is Cubase 10), not Cubase 10.5, please.

Hi Martin, I have the same problem with the soft elicenser (cubase 10.5 elements) as the three first users. Even if I tried to uninstall everything I can’t install the elc installation helper and the a failure message appears ( did it as administrator) and my windows are updated . Do you have any other ideas that can help me. Thank you!


Have you tried to uninstall eLCC completely (as described above) and install it again, please?

Same problem with Cubase Ai 10. Already tried to unistall everything and reinstall…nothing changes. I wish buy an upgrade from Ai to pro, but honestly I’m a bit upset and worried about all that stuff. The only thing left to try is to format and reinstall the operating sistem, but I hope there is another way to get out. Someone have solved?