Solo behavior question

By default, the second click on solo button or typing S key for the second time should un-solo the currently selected and soloed track, correct?

For me the second click mutes the selected soloed track, effectively muting all tracks.

How can get back to the default behavior?

EDIT: Noticed in key commands I had S for Edit > Solo, so switched it to Enable Solo for selected track in Project & Mix Console. The only thing that changed as result was that now S key doesn’t do anything in project, mix console OR editor. I do get notification popups like below. Solo button (mis)behaves like it used to; 1st click solo, 2nd click mute. Realized this is not the function I’m looking to change.

Screenshot 2021-10-09 105333

Screenshot 2021-10-09 105125

EDIT: Assigning S key command to Solo results in the same behavior I originally posted needing to change.


I guess, any of your track had been muted. Clock to the Disable all Mute Stated, please. Then try the Solo again.

Thanks, that was it.

I needed to first Disable all Mute States, then mute the tracks I wanted to stay muted regardless of the Solo status/toggle. Now Solo toggle works for the selected tracks as expected. I’m still not sure why I needed to do this.